summaryrefslogtreecommitdiff
path: root/libopenmpt
diff options
context:
space:
mode:
authorJames Cowgill <jcowgill@debian.org>2018-05-07 17:07:06 +0100
committerJames Cowgill <jcowgill@debian.org>2018-05-07 17:07:06 +0100
commit5b4812131c7a530e6a99e4ac2a539b296f29667a (patch)
treee751cc79c7733e9cfdd5de4d6bd4c67344e5d107 /libopenmpt
parentc995e8a34a0e305a46d6960fe6d2caea109352f6 (diff)
New upstream version 0.3.9
Diffstat (limited to 'libopenmpt')
-rw-r--r--libopenmpt/dox/changelog.md50
-rw-r--r--libopenmpt/dox/dependencies.md1
-rw-r--r--libopenmpt/libopenmpt_version.h2
-rw-r--r--libopenmpt/libopenmpt_version.mk4
4 files changed, 53 insertions, 4 deletions
diff --git a/libopenmpt/dox/changelog.md b/libopenmpt/dox/changelog.md
index 1dda37a..6ec40f7 100644
--- a/libopenmpt/dox/changelog.md
+++ b/libopenmpt/dox/changelog.md
@@ -5,6 +5,55 @@ Changelog {#changelog}
For fully detailed change log, please see the source repository directly. This
is just a high-level summary.
+### libopenmpt 0.3.9 (2018-04-29)
+
+ * [**Sec**] Possible write near address 0 in out-of-memory situations when
+ reading AMS files (r10149).
+
+ * [**Bug**] openmpt123: Fixed build failure in C++17 due to use of removed
+ feature `std::random_shuffle`.
+
+ * STM: Having both Bxx and Cxx commands in a pattern imported the Bxx command
+ incorrectly.
+ * STM: Last character of sample name was missing.
+ * Speed up reading of truncated ULT files.
+ * ULT: Portamento import was sometimes broken.
+ * The resonant filter was sometimes unstable when combining low-volume
+ samples, low cutoff and high mixing rates.
+
+### libopenmpt 0.3.8 (2018-04-08)
+
+ * [**Sec**] Possible out-of-bounds memory read with IT and MO3 files
+ containing many nested pattern loops (r10028).
+
+ * Keep track of active SFx macro during seeking.
+ * The "note cut" duplicate note action did not volume-ramp the previously
+ playing sample.
+ * A song starting with non-existing patterns could not be played.
+ * DSM: Support restart position and 16-bit samples.
+ * DTM: Import global volume.
+
+### libopenmpt 0.3.7 (2018-03-11)
+
+ * [**Bug**] libopenmpt did not build with NDK r13b on armeabi due to missing
+ `-latomic`.
+ * [**Bug**] xmp-openmpt: Sample rate and number of output channels were not
+ applied correctly when using per-file settings.
+
+ * [**Change**] foo_openmpt: foo_openmpt is now packaged as a fb2k-component
+ package for easier installation.
+
+ * IT: More accurate song length calculation for pattern loops that have no
+ start command and are following another pattern loop.
+ * IMF: Filter cutoff was upside down and the cutoff range was too small.
+ * MED: Correctly import patterns with less channels than the maximum used
+ amount. Import "STP" note stop command.
+ * DBM: Key Off and Set Envelope Position were imported incorrectly.
+ High sample offset (E7x) is now supported.
+ * DIGI / DBM: Arpeggio should not return to base note at end of row.
+ * Some filter changes through MIDI macros were not applied if the note volume
+ was set to 0 on the same row.
+
### libopenmpt 0.3.6 (2018-02-03)
* [**Sec**] Possible out-of-bounds memory read with malformed STP files.
@@ -27,7 +76,6 @@ is just a high-level summary.
* Tighten M15 and MOD file rejection heuristics.
* J2B: Ignore frequency limits from file header. Fixes Medivo.j2b, broken
since libopenmpt-0.2.6401-beta17.
- * STM: Last character of sample name was missing.
* ParamEq plugin center frequency was not limited correctly.
* libopenmpt_ext C API was not included in the documentation.
diff --git a/libopenmpt/dox/dependencies.md b/libopenmpt/dox/dependencies.md
index d689562..c06634b 100644
--- a/libopenmpt/dox/dependencies.md
+++ b/libopenmpt/dox/dependencies.md
@@ -38,6 +38,7 @@ Dependencies
particular:
* `char` can be `signed` or `unsigned`
* shifting signed values is implementation defined
+ * `signed` integer overflow is undefined
* `float` and `double` can be non-IEEE754
* Required compilers to use libopenmpt:
diff --git a/libopenmpt/libopenmpt_version.h b/libopenmpt/libopenmpt_version.h
index dbc1afe..bc19d8a 100644
--- a/libopenmpt/libopenmpt_version.h
+++ b/libopenmpt/libopenmpt_version.h
@@ -19,7 +19,7 @@
/*! \brief libopenmpt minor version number */
#define OPENMPT_API_VERSION_MINOR 3
/*! \brief libopenmpt patch version number */
-#define OPENMPT_API_VERSION_PATCH 6
+#define OPENMPT_API_VERSION_PATCH 9
/*! \brief libopenmpt pre-release tag */
#define OPENMPT_API_VERSION_PREREL ""
/*! \brief libopenmpt pre-release flag */
diff --git a/libopenmpt/libopenmpt_version.mk b/libopenmpt/libopenmpt_version.mk
index a3d74c7..c3cf173 100644
--- a/libopenmpt/libopenmpt_version.mk
+++ b/libopenmpt/libopenmpt_version.mk
@@ -1,8 +1,8 @@
LIBOPENMPT_VERSION_MAJOR=0
LIBOPENMPT_VERSION_MINOR=3
-LIBOPENMPT_VERSION_PATCH=6
+LIBOPENMPT_VERSION_PATCH=9
LIBOPENMPT_VERSION_PREREL=
LIBOPENMPT_LTVER_CURRENT=1
-LIBOPENMPT_LTVER_REVISION=6
+LIBOPENMPT_LTVER_REVISION=9
LIBOPENMPT_LTVER_AGE=1