summaryrefslogtreecommitdiff
path: root/libopenmpt
diff options
context:
space:
mode:
Diffstat (limited to 'libopenmpt')
-rw-r--r--libopenmpt/dox/changelog.md17
-rw-r--r--libopenmpt/libopenmpt.hpp2
-rw-r--r--libopenmpt/libopenmpt_impl.cpp2
-rw-r--r--libopenmpt/libopenmpt_version.h2
-rw-r--r--libopenmpt/libopenmpt_version.mk4
5 files changed, 21 insertions, 6 deletions
diff --git a/libopenmpt/dox/changelog.md b/libopenmpt/dox/changelog.md
index 6b4c678..5b98fcf 100644
--- a/libopenmpt/dox/changelog.md
+++ b/libopenmpt/dox/changelog.md
@@ -5,6 +5,16 @@ Changelog {#changelog}
For fully detailed change log, please see the source repository directly. This
is just a high-level summary.
+### libopenmpt 0.4.10 (2019-10-30)
+
+ * The "date" metadata could contain a bogus date for some older IT files.
+ * Do not apply global volume ramping from initial global volume when seeking.
+
+ * MTM: Sample loop length was off by one.
+ * PSM: Sample loop length was off by one in most files.
+
+ * mpg123: Update to v1.25.13 (2019-10-26).
+
### libopenmpt 0.4.9 (2019-10-02)
* [**Sec**] libmodplug: C API: Limit the length of strings copied to the
@@ -16,6 +26,7 @@ is just a high-level summary.
applies to strings encoded in arbitrary character encodings but the API
returns them converted to UTF-8, which can be longer. (reported by Antonio
Morales Maldonado of Semmle Security Research Team) (r12129)
+ ([CVE-2019-17113](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17113))
* [**Sec**] libmodplug: C++ API: Do not return 0 in
`CSoundFile::GetSampleName()` and `CSoundFile::GetInstrumentName()` when a
null output pointer is provided. This behaviour differed from libmodplug and
@@ -35,7 +46,7 @@ is just a high-level summary.
* J2B: Ignore notes with non-existing instrument (fixes Ending.j2b).
- * mpg123: Update to v1.25.13 (2019-08-24).
+ * mpg123: Update to v1.25.12 (2019-08-24).
* ogg: Update to v1.3.4. (2019-08-31).
* flac: Update to v1.3.3. (2019-08-04).
@@ -59,6 +70,7 @@ is just a high-level summary.
* [**Sec**] Possible crash during playback due out-of-bounds read in XM and
MT2 files (r11608).
+ ([CVE-2019-14380](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14380))
* Breaking out of a sustain loop through Note-Off sometimes didn't continue in
the regular sample loop.
@@ -81,6 +93,7 @@ is just a high-level summary.
* [**Sec**] Possible crash due to null-pointer access when doing a portamento
from an OPL instrument to an empty instrument note map slot (r11348).
+ ([CVE-2019-14381](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14381))
* [**Bug**] libopenmpt did not compile on Apple platforms in C++17 mode.
@@ -95,8 +108,10 @@ is just a high-level summary.
* [**Sec**] DSM: Assertion failure during file parsing with debug STLs
(r11209).
+ ([CVE-2019-14382](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14382))
* [**Sec**] J2B: Assertion failure during file parsing with debug STLs
(r11216).
+ ([CVE-2019-14383](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14383))
* S3M: Allow volume change of OPL instruments after Note Cut.
diff --git a/libopenmpt/libopenmpt.hpp b/libopenmpt/libopenmpt.hpp
index 55097f8..f16ccd6 100644
--- a/libopenmpt/libopenmpt.hpp
+++ b/libopenmpt/libopenmpt.hpp
@@ -251,7 +251,7 @@ LIBOPENMPT_CXX_API double could_open_probability( std::istream & stream, double
//! Roughly scan the input stream to find out whether libopenmpt might be able to open it
/*!
- \deprecated Please use openmpt::module::could_open_probability().
+ \deprecated Please use openmpt::could_open_probability().
*/
LIBOPENMPT_ATTR_DEPRECATED LIBOPENMPT_CXX_API LIBOPENMPT_DEPRECATED double could_open_propability( std::istream & stream, double effort = 1.0, std::ostream & log = std::clog );
diff --git a/libopenmpt/libopenmpt_impl.cpp b/libopenmpt/libopenmpt_impl.cpp
index 6ade376..1f74f1c 100644
--- a/libopenmpt/libopenmpt_impl.cpp
+++ b/libopenmpt/libopenmpt_impl.cpp
@@ -1133,7 +1133,7 @@ std::string module_impl::get_metadata( const std::string & key ) const {
} else if ( key == std::string("title") ) {
return mod_string_to_utf8( m_sndFile->GetTitle() );
} else if ( key == std::string("date") ) {
- if ( m_sndFile->GetFileHistory().empty() ) {
+ if ( m_sndFile->GetFileHistory().empty() || !m_sndFile->GetFileHistory().back().HasValidDate() ) {
return std::string();
}
return mpt::ToCharset(mpt::CharsetUTF8, m_sndFile->GetFileHistory().back().AsISO8601() );
diff --git a/libopenmpt/libopenmpt_version.h b/libopenmpt/libopenmpt_version.h
index 686c351..ad3941e 100644
--- a/libopenmpt/libopenmpt_version.h
+++ b/libopenmpt/libopenmpt_version.h
@@ -19,7 +19,7 @@
/*! \brief libopenmpt minor version number */
#define OPENMPT_API_VERSION_MINOR 4
/*! \brief libopenmpt patch version number */
-#define OPENMPT_API_VERSION_PATCH 9
+#define OPENMPT_API_VERSION_PATCH 10
/*! \brief libopenmpt pre-release tag */
#define OPENMPT_API_VERSION_PREREL ""
/*! \brief libopenmpt pre-release flag */
diff --git a/libopenmpt/libopenmpt_version.mk b/libopenmpt/libopenmpt_version.mk
index 59dd997..1dc9026 100644
--- a/libopenmpt/libopenmpt_version.mk
+++ b/libopenmpt/libopenmpt_version.mk
@@ -1,8 +1,8 @@
LIBOPENMPT_VERSION_MAJOR=0
LIBOPENMPT_VERSION_MINOR=4
-LIBOPENMPT_VERSION_PATCH=9
+LIBOPENMPT_VERSION_PATCH=10
LIBOPENMPT_VERSION_PREREL=
LIBOPENMPT_LTVER_CURRENT=1
-LIBOPENMPT_LTVER_REVISION=9
+LIBOPENMPT_LTVER_REVISION=10
LIBOPENMPT_LTVER_AGE=1