summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-29 18:53:24 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-29 18:56:49 +0200
commit66d05c79dcb9c142c62fd722a1849e3fecda854b (patch)
tree151f41c18d2d20b6922e8452ff31e2555c09c192
parentaa22ed80afe738ee79aec50c6770f8d5f3b71cd4 (diff)
Fixes in d/rules
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules12
2 files changed, 7 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index b949250..36a8475 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,10 @@ libosmo-netif (0.3.0-1~exp1) UNRELEASED; urgency=medium
* New upstream release
* libosmonetif4 -> libosmonetif6
+ * Removed commented out sections related to libosmonetif4-dbg
* Added debian/gbp.conf
+ * debian/rules:
+ - Do not use dpkg-parsechangelog anymore
-- Ruben Undheim <ruben.undheim@gmail.com> Thu, 09 Aug 2018 14:51:21 +0200
diff --git a/debian/rules b/debian/rules
index 28770ed..e0ee1d9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,23 +1,19 @@
#!/usr/bin/make -f
-DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
-VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+#export DH_VERBOSE=1
+
+include /usr/share/dpkg/pkg-info.mk
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-#export DH_VERBOSE=1
%:
dh $@ --with autoreconf
-#override_dh_strip:
-# dh_strip --dbg-package=libosmo-netif-dbg
-
override_dh_autoreconf:
- echo $(VERSION) > .tarball-version
+ echo $(DEB_VERSION_UPSTREAM) > .tarball-version
dh_autoreconf
override_dh_install: