From ae14aa44a516ee901d3bb67086deb753c5769977 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Thu, 28 Apr 2022 13:11:25 +0100 Subject: Add notes to libpipeline(3) of when functions were added * man/libpipeline.3 (DESCRIPTION, ENVIRONMENT): Add various "Added in" notes. * NEWS.md: Document this. --- NEWS.md | 5 +++++ man/libpipeline.3 | 31 +++++++++++++++++++++++++++++++ 2 files changed, 36 insertions(+) diff --git a/NEWS.md b/NEWS.md index 61fde31..82bef5b 100644 --- a/NEWS.md +++ b/NEWS.md @@ -1,3 +1,8 @@ +libpipeline 1.5.7 +================= + + * Add notes to libpipeline(3) of when functions were added. + libpipeline 1.5.6 (24 April 2022) ================================= diff --git a/man/libpipeline.3 b/man/libpipeline.3 index cf19907..79feb23 100644 --- a/man/libpipeline.3 +++ b/man/libpipeline.3 @@ -186,6 +186,10 @@ command .Sq echo foo bar is counted as having three arguments. .Pp +Added in +.Nm +1.1.0. +.Pp .It Ft void Fn pipecmd_nice "pipecmd *cmd" "int value" .Pp Set the @@ -210,6 +214,10 @@ Change the working directory to .Va directory while running this command. .Pp +Added in +.Nm +1.3.0. +.Pp .It Ft void Fn pipecmd_fchdir "pipecmd *cmd" "int directory_fd" .Pp Change the working directory to the directory given by the open file @@ -217,6 +225,10 @@ descriptor .Va directory_fd while running this command. .Pp +Added in +.Nm +1.4.0. +.Pp .It Xo Ft void .Fn pipecmd_setenv "pipecmd *cmd" "const char *name" "const char *value" .Xc @@ -243,6 +255,10 @@ Beware that this may cause unexpected failures, for example if some of the contents of the environment are necessary to execute programs at all (say, .Li PATH ) . .Pp +Added in +.Nm +1.1.0. +.Pp .It Xo Ft void .Fo pipecmd_pre_exec .Fa "pipecmd *cmd" @@ -263,6 +279,10 @@ This is similar to pipeline_install_post_fork, except that is specific to a single command rather than installing a global handler, and it runs slightly later (immediately before exec rather than immediately after fork). .Pp +Added in +.Nm +1.5.0. +.Pp .It Ft void Fn pipecmd_sequence_command "pipecmd *cmd" "pipecmd *child" .Pp Add a command to a sequence created using @@ -282,6 +302,10 @@ The caller should free the result. Execute a single command, replacing the current process. Never returns, instead exiting non-zero on failure. .Pp +Added in +.Nm +1.1.0. +.Pp .It Ft void Fn pipecmd_free "pipecmd *cmd" .Pp Destroy a command. @@ -490,6 +514,10 @@ if .Va n is out of range or if the command has already exited and been reaped. .Pp +Added in +.Nm +1.2.0. +.Pp .It Ft "FILE *" Ns Fn pipeline_get_infile "pipeline *p" .It Ft "FILE *" Ns Fn pipeline_get_outfile "pipeline *p" .Pp @@ -721,6 +749,9 @@ environment variable is set to any value, then .Nm will refrain from printing an error message when a subprocess is terminated by a signal. +Added in +.Nm +1.4.0. .Sh EXAMPLES In the following examples, function names starting with .Li pipecmd_ -- cgit v1.2.3 From e95a2b5fa919726580bb6695c925ca7b0bfcf1ac Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 12:29:08 +0100 Subject: Transferred Git repository to new group * README.md: Change GitLab URL to https://gitlab.com/libpipeline/libpipeline. * NEWS.md: Document this. --- NEWS.md | 1 + README.md | 6 +++--- 2 files changed, 4 insertions(+), 3 deletions(-) diff --git a/NEWS.md b/NEWS.md index 82bef5b..91a419b 100644 --- a/NEWS.md +++ b/NEWS.md @@ -2,6 +2,7 @@ libpipeline 1.5.7 ================= * Add notes to libpipeline(3) of when functions were added. + * Transferred Git repository to https://gitlab.com/libpipeline/libpipeline. libpipeline 1.5.6 (24 April 2022) ================================= diff --git a/README.md b/README.md index f84e222..fc2fd42 100644 --- a/README.md +++ b/README.md @@ -1,6 +1,6 @@ # libpipeline, a pipeline manipulation library -Git repository: https://gitlab.com/cjwatson/libpipeline +Git repository: https://gitlab.com/libpipeline/libpipeline libpipeline is a C library for setting up and running pipelines of processes, without needing to involve shell command-line parsing which is @@ -230,6 +230,6 @@ design review, and Kees Cook and Matthias Klose for helpful conversations. ## Bug reporting You can [report bugs on -GitLab](https://gitlab.com/cjwatson/libpipeline/-/issues), or see [bugs from -before the migration to +GitLab](https://gitlab.com/libpipeline/libpipeline/-/issues), or see [bugs +from before the migration to GitLab](https://savannah.nongnu.org/bugs/?group=libpipeline). -- cgit v1.2.3 From 9c4efd8811fd12a275f80539c56e7fb8b59d0127 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 12:48:07 +0100 Subject: Add GitLab Pages site * .gitlab-ci.yml (stages): Add deploy. (pages): New job. * web/index.html, web/libpipeline-lightning-talk.odp, web/standard.css, web/white.css: New files. --- .gitlab-ci.yml | 18 ++++ web/index.html | 179 +++++++++++++++++++++++++++++++++++++ web/libpipeline-lightning-talk.odp | Bin 0 -> 17004 bytes web/standard.css | 133 +++++++++++++++++++++++++++ web/white.css | 2 + 5 files changed, 332 insertions(+) create mode 100644 web/index.html create mode 100644 web/libpipeline-lightning-talk.odp create mode 100644 web/standard.css create mode 100644 web/white.css diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml index 7eb1fcc..27fc5ac 100644 --- a/.gitlab-ci.yml +++ b/.gitlab-ci.yml @@ -5,6 +5,7 @@ variables: GIT_DEPTH: 0 stages: + - deploy - bootstrap - build - upload @@ -24,6 +25,23 @@ pre-commit: paths: - .cache/pre-commit +pages: + stage: deploy + before_script: + - apt -qq update + - apt -y -qq install bsdextrautils mandoc + script: + - rm -rf public + - cp -a web public + - mandoc -T ascii man/libpipeline.3 | col -b >public/libpipeline.3.txt + - mandoc -T html man/libpipeline.3 >public/libpipeline.3.html + artifacts: + paths: + - public + expire_in: 30 days + rules: + - if: $CI_COMMIT_BRANCH == "main" + bootstrap: stage: bootstrap before_script: diff --git a/web/index.html b/web/index.html new file mode 100644 index 0000000..cb442d7 --- /dev/null +++ b/web/index.html @@ -0,0 +1,179 @@ + + + + +libpipeline - pipeline manipulation library + + + + + + + + + +

libpipeline - pipeline manipulation library

+ +

Summary

+ +

libpipeline is a C library for manipulating pipelines of subprocesses in +a flexible and convenient way. It is available in at least the following +operating systems:

+ + + +

For macOS, you can install libpipeline using +Homebrew with +this "tap".

+ +

Description

+ +

When I took over man-db in 2001, +one of the major problems that became evident after maintaining it for a +while was the way it handled subprocesses. The nature of man and friends +means that it spends a lot of time calling sequences of programs such as +zsoelim < input-file | tbl | nroff -mandoc -Tutf8. Back then, +it was using C library facilities such as system and +popen for all this, and I had to deal with several bugs where +those functions were being called with untrusted input as arguments without +properly escaping metacharacters. Of course it was possible to chase around +every such call inserting appropriate escaping functions, but this was +always bound to be error-prone and one of the tasks that rapidly became +important to me was arranging to start subprocesses in a way that was +fundamentally immune to this kind of bug.

+ +

In higher-level languages, there are usually standard constructs which +are safer than just passing a command line to the shell. For example, in +Perl you can use system([$command, $arg1, $arg2, ...]) to +invoke a program with arguments without the interference of the shell, and +perlipc(1) describes various facilities for connecting them +together. In Python, the +subprocess +module allows you to create pipelines easily and safely (as long as you +remember the +SIGPIPE +gotcha). C has the fork and execve +primitives, but assembling these to construct full-blown pipelines correctly +is difficult and error-prone, so many programmers don't bother and use the +simple but unsafe library facilities instead.

+ +

libpipeline solves this problem. In the following examples, function +names starting with pipecmd_ or pipeline_ are real +functions in the library, while any other function names are pseudocode.

+ +

Constructing the simplified example pipeline from my first paragraph +using this library looks like this:

+ +
+pipeline *p;
+int status;
+
+p = pipeline_new ();
+pipeline_want_infile (p, "input-file");
+pipeline_command_args (p, "zsoelim", NULL);
+pipeline_command_args (p, "tbl", NULL);
+pipeline_command_args (p, "nroff", "-mandoc", "-Tutf8", NULL);
+status = pipeline_run (p);
+
+ +

You might want to construct a command more dynamically:

+ +
+pipecmd *manconv = pipecmd_new_args ("manconv", "-f", from_code,
+                                     "-t", "UTF-8", NULL);
+if (quiet)
+	pipecmd_arg (manconv, "-q");
+pipeline_command (p, manconv);
+
+ +

Perhaps you want an environment variable set only while running a certain +command:

+ +
+pipecmd *less = pipecmd_new ("less");
+pipecmd_setenv (less, "LESSCHARSET", lesscharset);
+
+ +

You might find yourself needing to pass the output of one pipeline to +several other pipelines, in a "tee" arrangement:

+ +
+pipeline *source, *sink1, *sink2;
+
+source = make_source ();
+sink1 = make_sink1 ();
+sink2 = make_sink2 ();
+pipeline_connect (source, sink1, sink2, NULL);
+/* Pump data among these pipelines until there's nothing left. */
+pipeline_pump (source, sink1, sink2, NULL);
+pipeline_free (sink2);
+pipeline_free (sink1);
+pipeline_free (source);
+
+ +

Maybe one of your commands is actually an in-process function, rather +than an external program:

+ +
+pipecmd *inproc = pipecmd_new_function ("in-process", &func, NULL, NULL);
+pipeline_command (p, inproc);
+
+ +

Sometimes your program needs to consume the output of a pipeline, rather +than sending it all to some other subprocess:

+ +
+pipeline *p = make_pipeline ();
+const char *line;
+
+pipeline_want_out (p, -1);
+pipeline_start (p);
+line = pipeline_peekline (p);
+if (!strstr (line, "coding: UTF-8"))
+	printf ("Unicode text follows:\n");
+while (line = pipeline_readline (p))
+	printf ("  %s", line);
+pipeline_free (p);
+
+ +

See the +Savannah +project or the +GitLab repository +for more information. The latest release is 1.5.3, made on 2020-08-13.

+ +

The libpipeline(3) manual page is available in +HTML and +text.

+ +

Installation

+ +

If your distribution includes a package of libpipeline, it's usually best +to install that. However, if you need to install it starting from source +code, then you will need these separate packages installed before +configuring libpipeline in order to run its test suite:

+ + + +
+ +
+This Web page is created and maintained by +Colin Watson. +
+Last modified: $Date: 2020/11/25 23:31:33 $ +
+ + + diff --git a/web/libpipeline-lightning-talk.odp b/web/libpipeline-lightning-talk.odp new file mode 100644 index 0000000..d0da11f Binary files /dev/null and b/web/libpipeline-lightning-talk.odp differ diff --git a/web/standard.css b/web/standard.css new file mode 100644 index 0000000..49f99d4 --- /dev/null +++ b/web/standard.css @@ -0,0 +1,133 @@ +body { background-color: #FFFFB0; color: #000000 } +a { border: 0; } +a:link { color: #0000FF; } +a:visited { color: #800080; } +img { border: 0; } +h1 { font-family: sans-serif; + font-size: 24pt; + color: #000080; } +h1 a { color: #0000FF; } +h2 { font-family: sans-serif; + font-size: 20pt; + color: #000080; } +h2 a { color: #0000FF; } +h3 { font-family: sans-serif; + font-size: 16pt; + color: #000080; } +h3 a { color: #0000FF; } +address { font-family: sans-serif; + font-size: 10pt; } +.center { text-align: center; } +.clearright { clear: right; } +.logo { float: right; + margin-left: 5px; } +.pre { white-space: pre; } +.urgent { color: #FF0000; + font-style: italic; } +table { border-width: 0; } +table.tdtop td { + vertical-align: top; +} + +/* drop caps */ + +p.illuminated:first-letter { + font-size: 300%; + font-weight: bold; +} + +/* frame implementation */ + +#main { + position: absolute; + width: auto; + height: auto; + top: 0; + bottom: auto; + left: 160px; + right: 0; +} +#menubar { + position: fixed; + width: 150px; + height: auto; + top: 10px; + bottom: auto; + left: 10px; + right: auto; +} +#submain { + position: absolute; + width: auto; + height: auto; + top: 0; + bottom: 40px; + left: 160px; + right: 0; + overflow: scroll; +} +#submenubar { + position: fixed; + width: auto; + height: 30px; + top: auto; + bottom: 0; + left: 160px; + right: 0; + text-align: center; +} + +.navigation { + font: bold 100% Arial, Helvetica, sans-serif; +} + +.navigation { + text-align: center; +} + +.navigation a { + text-decoration: none; +} + +.navigation a:link { + color: blue; +} + +.navigation a:visited { + color: purple; +} + +.navigation a:hover { + background-color: #D0D090; +} + +.navigation a:hover:link { + color: #000088; +} + +.navigation a:hover:visited { + color: #660066; +} + +#menubar.navigation { + text-align: left; +} + +#menubar.navigation p { + margin: 8px 4px 8px 2px; +} + +#menubar.navigation a { + display: block; +} + +#menubar.navigation .subnav { + margin: 2px 2px 12px 12px; + font-size: 75%; +} + +#menubar.navigation .subnav a { + display: inline; +} + +/* vim: set sts=2 sw=2: */ diff --git a/web/white.css b/web/white.css new file mode 100644 index 0000000..cc76b04 --- /dev/null +++ b/web/white.css @@ -0,0 +1,2 @@ +body { background-color: #FFFFFF; } +a.navimage { color: #FFFFFF; border: 0; } -- cgit v1.2.3 From 2c1989273a20610994b02db90deeac5bdaeaf2cd Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 12:57:54 +0100 Subject: web: Assorted URL updates * web/index.html: Update Git URLs to GitLab. Chase various redirects and/or switch to HTTPS. Remove old Savannah link. --- web/index.html | 26 +++++++++++--------------- 1 file changed, 11 insertions(+), 15 deletions(-) diff --git a/web/index.html b/web/index.html index cb442d7..9f5cbb6 100644 --- a/web/index.html +++ b/web/index.html @@ -6,9 +6,7 @@ libpipeline - pipeline manipulation library - - - + @@ -22,12 +20,12 @@ a flexible and convenient way. It is available in at least the following operating systems:

For macOS, you can install libpipeline using @@ -56,10 +54,10 @@ Perl you can use system([$command, $arg1, $arg2, ...]) to invoke a program with arguments without the interference of the shell, and perlipc(1) describes various facilities for connecting them together. In Python, the -subprocess +subprocess module allows you to create pipelines easily and safely (as long as you remember the -SIGPIPE +SIGPIPE gotcha). C has the fork and execve primitives, but assembling these to construct full-blown pipelines correctly is difficult and error-prone, so many programmers don't bother and use the @@ -145,8 +143,6 @@ pipeline_free (p);

See the -Savannah -project or the GitLab repository for more information. The latest release is 1.5.3, made on 2020-08-13.

@@ -162,8 +158,8 @@ code, then you will need these separate packages installed before configuring libpipeline in order to run its test suite:


-- cgit v1.2.3 From 73d6cfdaa21c8e9e7506e4197865252399e0d2bf Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 13:01:47 +0100 Subject: web: Fix last-modified date generation * .gitlab-ci.yml: Replace `@DATE@` with the current date in `public/index.html`. * web/index.html: Use `@DATE@` template. --- .gitlab-ci.yml | 1 + web/index.html | 2 +- 2 files changed, 2 insertions(+), 1 deletion(-) diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml index 27fc5ac..ffd6bbc 100644 --- a/.gitlab-ci.yml +++ b/.gitlab-ci.yml @@ -33,6 +33,7 @@ pages: script: - rm -rf public - cp -a web public + - sed -i "s/@DATE@/$(date -I)/" public/index.html - mandoc -T ascii man/libpipeline.3 | col -b >public/libpipeline.3.txt - mandoc -T html man/libpipeline.3 >public/libpipeline.3.html artifacts: diff --git a/web/index.html b/web/index.html index 9f5cbb6..0e28312 100644 --- a/web/index.html +++ b/web/index.html @@ -168,7 +168,7 @@ configuring libpipeline in order to run its test suite:

This Web page is created and maintained by Colin Watson.
-Last modified: $Date: 2020/11/25 23:31:33 $ +Last modified: @DATE@ -- cgit v1.2.3 From 7efd46493c27362d88e8f7624999062a2683b9f6 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 13:03:30 +0100 Subject: web: Update last release * web/index.html: Update to 1.5.6. --- web/index.html | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/web/index.html b/web/index.html index 0e28312..e7433ae 100644 --- a/web/index.html +++ b/web/index.html @@ -144,7 +144,7 @@ pipeline_free (p);

See the GitLab repository -for more information. The latest release is 1.5.3, made on 2020-08-13.

+for more information. The latest release is 1.5.6, made on 2022-04-24.

The libpipeline(3) manual page is available in HTML and -- cgit v1.2.3 From ff4698b37170fd166f8d2ea2b0701c4422a26c0f Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 13:24:28 +0100 Subject: Update home page URL * README.md: Use `https://libpipeline.gitlab.io/libpipeline/`. * lib/libpipeline.pc.in (URL): Likewise. --- README.md | 3 ++- lib/libpipeline.pc.in | 2 +- 2 files changed, 3 insertions(+), 2 deletions(-) diff --git a/README.md b/README.md index fc2fd42..a970033 100644 --- a/README.md +++ b/README.md @@ -9,7 +9,8 @@ laboriously construct pipelines using lower-level primitives such as fork(2) and execve(2). Full programmers' documentation may be found using `man libpipeline`, and -the [project homepage](https://nongnu.org/libpipeline/) has more background. +the [project homepage](https://libpipeline.gitlab.io/libpipeline/) has more +background. ## Installation diff --git a/lib/libpipeline.pc.in b/lib/libpipeline.pc.in index cc8a428..592e272 100644 --- a/lib/libpipeline.pc.in +++ b/lib/libpipeline.pc.in @@ -25,6 +25,6 @@ includedir=@includedir@ Name: @PACKAGE_NAME@ Description: Pipeline manipulation library Version: @PACKAGE_VERSION@ -URL: https://nongnu.org/libpipeline/ +URL: https://libpipeline.gitlab.io/libpipeline/ Libs: -L${libdir} -lpipeline Cflags: -I${includedir} -- cgit v1.2.3 From 8d869994243666bdc750560d92121a2602864b30 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 3 Jun 2022 13:29:24 +0100 Subject: Update manual page date * man/libpipeline.3 (.Dd): Update to the date of the last substantial modification. Leaving this as 2010 suggested more antiquity than we need to suggest. --- man/libpipeline.3 | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/man/libpipeline.3 b/man/libpipeline.3 index 79feb23..347414b 100644 --- a/man/libpipeline.3 +++ b/man/libpipeline.3 @@ -1,4 +1,4 @@ -.\" Copyright (C) 2010-2017 Colin Watson. +.\" Copyright (C) 2010-2022 Colin Watson. .\" .\" This file is part of libpipeline. .\" @@ -16,7 +16,7 @@ .\" along with libpipeline; if not, write to the Free Software .\" Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 .\" USA. -.Dd October 11, 2010 +.Dd April 28, 2022 .Os GNU .ds volume-operating-system GNU .Dt LIBPIPELINE 3 -- cgit v1.2.3 From 417fc08d7b2930504d59f9fc204cdc6f7a48e9a5 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Fri, 12 Aug 2022 01:06:13 +0100 Subject: Update pre-commit hooks * .pre-commit-config.yaml (pre-commit-hooks): Update to v4.3.0. (clang-format): Update to v14.0.6. --- .pre-commit-config.yaml | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml index 6b7d032..6c7a38f 100644 --- a/.pre-commit-config.yaml +++ b/.pre-commit-config.yaml @@ -2,7 +2,7 @@ # See https://pre-commit.com/hooks.html for more hooks repos: - repo: https://github.com/pre-commit/pre-commit-hooks - rev: v4.2.0 + rev: v4.3.0 hooks: - id: check-added-large-files - id: check-yaml @@ -10,6 +10,6 @@ repos: - id: trailing-whitespace exclude: ChangeLog-2013 - repo: https://github.com/pre-commit/mirrors-clang-format - rev: v14.0.1 + rev: v14.0.6 hooks: - id: clang-format -- cgit v1.2.3 From b1ce62a36f5095f0294bad0551b08762164d3e7c Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Sun, 13 Nov 2022 19:52:37 +0000 Subject: Make socketpair configure tests compatible with C23 K&R-style zero-argument function definitions will no longer be permitted. * m4/pipeline-socketpair.m4 (PIPELINE_SOCKETPAIR_PIPE, PIPELINE_SOCKETPAIR_MODE): Use `int main(void)`, not `int main()`. * NEWS.md: Document this. --- NEWS.md | 2 ++ m4/pipeline-socketpair.m4 | 6 +++--- 2 files changed, 5 insertions(+), 3 deletions(-) diff --git a/NEWS.md b/NEWS.md index 91a419b..7357afe 100644 --- a/NEWS.md +++ b/NEWS.md @@ -3,6 +3,8 @@ libpipeline 1.5.7 * Add notes to libpipeline(3) of when functions were added. * Transferred Git repository to https://gitlab.com/libpipeline/libpipeline. + * Make `socketpair` tests used by `./configure --enable-socketpair-pipe` + compatible with C23. libpipeline 1.5.6 (24 April 2022) ================================= diff --git a/m4/pipeline-socketpair.m4 b/m4/pipeline-socketpair.m4 index d62b568..9b6d834 100644 --- a/m4/pipeline-socketpair.m4 +++ b/m4/pipeline-socketpair.m4 @@ -1,4 +1,4 @@ -# pipeline-socketpair.m4 serial 2 +# pipeline-socketpair.m4 serial 3 dnl dnl Check if the socketpair(2) system call can be used dnl and should be used as a fast replacement for pipe(2) @@ -28,7 +28,7 @@ static void sigpipe(int sig) _exit(0); } -int main() +int main(void) { const char test[] = "May use socketpair(2) instead of pipe(2)\n"; char buf[256]; @@ -88,7 +88,7 @@ AC_DEFUN([PIPELINE_SOCKETPAIR_MODE], # define SHUT_WR 1 #endif -int main() +int main(void) { int sfd[2]; struct stat st[2]; -- cgit v1.2.3 From c9662e67d575299df2b87bc70f0e4865f04a8f01 Mon Sep 17 00:00:00 2001 From: Colin Watson Date: Sun, 13 Nov 2022 22:06:58 +0000 Subject: Version: 1.5.7 * lib/Makefile.am (libpipeline_la_LDFLAGS): Bump -version-info to 6:7:5. --- NEWS.md | 4 ++-- configure.ac | 2 +- lib/Makefile.am | 2 +- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/NEWS.md b/NEWS.md index 7357afe..ba8aaf8 100644 --- a/NEWS.md +++ b/NEWS.md @@ -1,5 +1,5 @@ -libpipeline 1.5.7 -================= +libpipeline 1.5.7 (13 November 2022) +==================================== * Add notes to libpipeline(3) of when functions were added. * Transferred Git repository to https://gitlab.com/libpipeline/libpipeline. diff --git a/configure.ac b/configure.ac index 663ea44..b6e2f25 100644 --- a/configure.ac +++ b/configure.ac @@ -22,7 +22,7 @@ dnl Process this file with autoconf to produce a configure script. m4_pattern_forbid([^PIPELINE_]) # Initialise and check we're in the correct directory. -AC_INIT([libpipeline], [1.5.6], [cjwatson@debian.org]) +AC_INIT([libpipeline], [1.5.7], [cjwatson@debian.org]) AC_CONFIG_AUX_DIR([build-aux]) AM_INIT_AUTOMAKE([1.11 -Wall -Werror foreign]) AM_MAINTAINER_MODE diff --git a/lib/Makefile.am b/lib/Makefile.am index 5695392..844c4ef 100644 --- a/lib/Makefile.am +++ b/lib/Makefile.am @@ -42,7 +42,7 @@ libpipeline_la_LIBADD = ../gl/lib/libgnu.la $(LTLIBOBJS) libpipeline_la_LDFLAGS = \ -export-symbols-regex '^(pipecmd|pipeline)_' \ -no-undefined \ - -version-info 6:6:5 + -version-info 6:7:5 pkgconfigdir = $(libdir)/pkgconfig pkgconfig_DATA = libpipeline.pc -- cgit v1.2.3