summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-05-08 23:10:11 +0200
committerLinus Nordberg <linus@nordberg.se>2013-05-08 23:10:11 +0200
commitde670651b8d513c3956fc8618bca303ba55a04f4 (patch)
tree4da41e26419c6ad4970906b40eb43852b557fa08
parentf4608111b51edf1744cef31306d6bf06129dd591 (diff)
Revert "Bump library interface revision."
So there were two things wrong with that commit. 1. Library interface revision should be bumped only immediately before a public release. 2. Given the changes in the library, it should change to 0:1:0 since the interface didn't change (including not being extended). This reverts commit b9e967b3cde6af41cd0e863e9ff073897019625a. Conflicts: lib/Makefile.am
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 8f86aa4..237294a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -67,5 +67,5 @@ EXTRA_DIST = HACKING LICENSE libradsec.spec radsec.sym
AM_DISTCHECK_CONFIGURE_FLAGS = --enable-tls --enable-tls-psk
libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
-libradsec_la_LDFLAGS = -version-info 1:0:0 -export-symbols $(srcdir)/radsec.sym
+libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols $(srcdir)/radsec.sym
libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT