summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Hartman <hartmans@debian.org>2012-01-25 11:54:08 -0500
committerSam Hartman <hartmans@debian.org>2012-01-25 11:54:08 -0500
commit2885b8ed2ec77988ff3188f1b6a8cb9f937fc759 (patch)
tree57f12e4794a449586d462a21df1ad0efe5d3a2ed
parent5f617fbf7f4c5dcb39fa5f8216d6c2ae225183b2 (diff)
autoreconf
-rw-r--r--lib/Makefile.in22
-rwxr-xr-xlib/configure23
2 files changed, 27 insertions, 18 deletions
diff --git a/lib/Makefile.in b/lib/Makefile.in
index d6384c7..371cba1 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -41,9 +41,9 @@ host_triplet = @host@
subdir = .
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(srcdir)/config.h.in \
- $(top_srcdir)/configure COPYING build-aux/config.guess \
- build-aux/config.sub build-aux/depcomp build-aux/install-sh \
- build-aux/ltmain.sh build-aux/missing
+ $(srcdir)/libradsec.spec.in $(top_srcdir)/configure COPYING \
+ build-aux/config.guess build-aux/config.sub build-aux/depcomp \
+ build-aux/install-sh build-aux/ltmain.sh build-aux/missing
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/libtool.m4 \
$(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
@@ -55,7 +55,7 @@ am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
configure.lineno config.status.lineno
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = config.h
-CONFIG_CLEAN_FILES =
+CONFIG_CLEAN_FILES = libradsec.spec
CONFIG_CLEAN_VPATH_FILES =
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
@@ -84,7 +84,9 @@ libradsec_la_LIBADD =
am__libradsec_la_SOURCES_DIST = compat.c conf.c conn.c debug.c err.c \
event.c packet.c peer.c radsec.c request.c send.c tcp.c udp.c \
rsp_debug.c rsp_hash.c rsp_list.c rsp_util.c tls.c \
- rsp_tlscommon.c
+ rsp_tlscommon.c compat.h conn.h debug.h err.h event.h packet.h \
+ peer.h rsp_debug.h rsp_hash.h rsp_list.h rsp_tlscommon.h \
+ rsp_util.h tcp.h tls.h udp.h
@RS_ENABLE_TLS_TRUE@am__objects_1 = libradsec_la-tls.lo \
@RS_ENABLE_TLS_TRUE@ libradsec_la-rsp_tlscommon.lo
am_libradsec_la_OBJECTS = libradsec_la-compat.lo libradsec_la-conf.lo \
@@ -129,7 +131,6 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGETS:-recursive=) \
distdir dist dist-all distcheck
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = $(SUBDIRS)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -280,14 +281,19 @@ top_srcdir = @top_srcdir@
AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = . examples include
+DIST_SUBDIRS = tests ${SUBDIRS}
INCLUDES = -I$(srcdir)/include -I$(srcdir)/radsecproxy-includes
AM_CFLAGS = -Wall -g
lib_LTLIBRARIES = libradsec.la
libradsec_la_SOURCES = compat.c conf.c conn.c debug.c err.c event.c \
packet.c peer.c radsec.c request.c send.c tcp.c udp.c \
- rsp_debug.c rsp_hash.c rsp_list.c rsp_util.c $(am__append_1)
+ rsp_debug.c rsp_hash.c rsp_list.c rsp_util.c $(am__append_1) \
+ compat.h conn.h debug.h err.h event.h packet.h peer.h \
+ rsp_debug.h rsp_hash.h rsp_list.h rsp_tlscommon.h rsp_util.h \
+ tcp.h tls.h udp.h
libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
libradsec_la_CFLAGS = $(AM_CFLAGS) -Werror # -DDEBUG -DDEBUG_LEVENT
+EXTRA_DIST = libradsec.spec radsec.sym
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
@@ -344,6 +350,8 @@ $(srcdir)/config.h.in: $(am__configure_deps)
distclean-hdr:
-rm -f config.h stamp-h1
+libradsec.spec: $(top_builddir)/config.status $(srcdir)/libradsec.spec.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
install-libLTLIBRARIES: $(lib_LTLIBRARIES)
@$(NORMAL_INSTALL)
test -z "$(libdir)" || $(MKDIR_P) "$(DESTDIR)$(libdir)"
diff --git a/lib/configure b/lib/configure
index 0cb96ce..f9983a3 100755
--- a/lib/configure
+++ b/lib/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.67 for libradsec 0.0.2-dev.
+# Generated by GNU Autoconf 2.67 for libradsec 0.0.2.dev.
#
# Report bugs to <linus+libradsec@nordu.net>.
#
@@ -701,8 +701,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='libradsec'
PACKAGE_TARNAME='libradsec'
-PACKAGE_VERSION='0.0.2-dev'
-PACKAGE_STRING='libradsec 0.0.2-dev'
+PACKAGE_VERSION='0.0.2.dev'
+PACKAGE_STRING='libradsec 0.0.2.dev'
PACKAGE_BUGREPORT='linus+libradsec@nordu.net'
PACKAGE_URL=''
@@ -1417,7 +1417,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures libradsec 0.0.2-dev to adapt to many kinds of systems.
+\`configure' configures libradsec 0.0.2.dev to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1487,7 +1487,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of libradsec 0.0.2-dev:";;
+ short | recursive ) echo "Configuration of libradsec 0.0.2.dev:";;
esac
cat <<\_ACEOF
@@ -1587,7 +1587,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-libradsec configure 0.0.2-dev
+libradsec configure 0.0.2.dev
generated by GNU Autoconf 2.67
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -2063,7 +2063,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by libradsec $as_me 0.0.2-dev, which was
+It was created by libradsec $as_me 0.0.2.dev, which was
generated by GNU Autoconf 2.67. Invocation command line was
$ $0 $@
@@ -2882,7 +2882,7 @@ fi
# Define the identity of the package.
PACKAGE='libradsec'
- VERSION='0.0.2-dev'
+ VERSION='0.0.2.dev'
cat >>confdefs.h <<_ACEOF
@@ -11475,7 +11475,7 @@ fi
done
-ac_config_files="$ac_config_files Makefile include/Makefile examples/Makefile tests/Makefile"
+ac_config_files="$ac_config_files Makefile libradsec.spec include/Makefile examples/Makefile tests/Makefile"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -12007,7 +12007,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by libradsec $as_me 0.0.2-dev, which was
+This file was extended by libradsec $as_me 0.0.2.dev, which was
generated by GNU Autoconf 2.67. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -12073,7 +12073,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-libradsec config.status 0.0.2-dev
+libradsec config.status 0.0.2.dev
configured by $0, generated by GNU Autoconf 2.67,
with options \\"\$ac_cs_config\\"
@@ -12461,6 +12461,7 @@ do
"depfiles") CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
"libtool") CONFIG_COMMANDS="$CONFIG_COMMANDS libtool" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
+ "libradsec.spec") CONFIG_FILES="$CONFIG_FILES libradsec.spec" ;;
"include/Makefile") CONFIG_FILES="$CONFIG_FILES include/Makefile" ;;
"examples/Makefile") CONFIG_FILES="$CONFIG_FILES examples/Makefile" ;;
"tests/Makefile") CONFIG_FILES="$CONFIG_FILES tests/Makefile" ;;