summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkolla <kolla>2009-04-03 06:41:07 +0000
committerkolla <kolla@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2009-04-03 06:41:07 +0000
commit431f10f3a0101479e1de1776e51cf9b2859e86f9 (patch)
treea6b896ddd7ce152377555724e2a14d47c7cc8adc
parenta0b4520dc78864889e93ab3ee5583bcd908c6c41 (diff)
Fixed for catgconf
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@498 e88ac4ed-0b26-0410-9574-a7f39faa03bf
-rw-r--r--Makefile.am41
1 files changed, 25 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index 1422223..6b52273 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,19 +1,20 @@
-sbin_PROGRAMS = radsecproxy
+sbin_PROGRAMS = radsecproxy
+bin_PROGRAMS = catgconf
radsecproxy_SOURCES = radsecproxy.c \
- tlscommon.c \
+ tlscommon.c \
gconfig.c \
util.c \
debug.c \
list.c \
hash.c \
- tlv11.c \
- hostport.c \
- radmsg.c \
- udp.c \
- tcp.c \
- tls.c \
- dtls.c \
+ tlv11.c \
+ hostport.c \
+ radmsg.c \
+ udp.c \
+ tcp.c \
+ tls.c \
+ dtls.c \
radsecproxy.h \
tlscommon.h \
gconfig.h \
@@ -21,17 +22,25 @@ radsecproxy_SOURCES = radsecproxy.c \
util.h \
list.h \
hash.h \
- tlv11.h \
- hostport.h \
- radmsg.h \
- udp.h \
- tcp.h \
- tls.h \
- dtls.h
+ tlv11.h \
+ hostport.h \
+ radmsg.h \
+ udp.h \
+ tcp.h \
+ tls.h \
+ dtls.h
+
+catgconf_SOURCES = debug.c \
+ util.c \
+ gconfig.c \
+ catgconf.c
radsecproxy_CFLAGS = -g @SSL_CFLAGS@ @TARGET_CFLAGS@
radsecproxy_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
radsecproxy_LDADD = @SSL_LIBS@
+catgconf_CFLAGS = -g @TARGET_CFLAGS@
+catgconf_LDFLAGS = @TARGET_LDFLAGS@
+
dist_sysconf_DATA = $(srcdir)/radsecproxy.conf-example
dist_man_MANS = radsecproxy.1 radsecproxy.conf.5