summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Hartman <hartmans@debian.org>2019-01-02 07:05:03 -0500
committerSam Hartman <hartmans@debian.org>2019-01-02 07:05:03 -0500
commit49b19b828f9c697ebf403402f4ee6ec6c5467d13 (patch)
tree7e993b0ba6de0a17e4294e4501ddec5c6267af91
parentbd06eb9c740a0cd7188710a8ed2d36526ca5d71e (diff)
parentc71a10b4f5dfcdb765dfa08ed263bb574cdf778b (diff)
Merge branch 'debian' into dgit
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules2
-rw-r--r--tls.c8
4 files changed, 15 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e7d986c..9942a11 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libradsec (0.0.5-5) unstable; urgency=high
+
+ * Fix assert, necessary for library to work with OpenSSL 1.1.1.
+
+ -- Sam Hartman <hartmans@debian.org> Wed, 02 Jan 2019 07:01:03 -0500
+
libradsec (0.0.5-4) unstable; urgency=medium
* Fix problems detected by better warnings in gcc 7, Closes: #853506
diff --git a/debian/control b/debian/control
index c7bd47c..d964542 100644
--- a/debian/control
+++ b/debian/control
@@ -1,5 +1,5 @@
Source: libradsec
-Priority: extra
+Priority: optional
Maintainer: Sam Hartman <hartmans@debian.org>
Build-Depends: debhelper (>= 9), autotools-dev, libconfuse-dev, libssl-dev, libevent-dev (>= 2.0), dh-autoreconf
Standards-Version: 3.9.8
diff --git a/debian/rules b/debian/rules
index ec3ee90..0ff0b3f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,3 +13,5 @@
override_dh_auto_configure:
dh_auto_configure -- --enable-tls --enable-tls-psk CFLAGS='$(shell dpkg-buildflags --get CFLAGS) -pthread'
+override_dh_makeshlibs:
+ dh_makeshlibs -plibradsec0 -V'libradsec0 (>= 0.0.5-5)'
diff --git a/tls.c b/tls.c
index 7b33d8e..366286f 100644
--- a/tls.c
+++ b/tls.c
@@ -232,9 +232,13 @@ tls_init ()
{
SSL_load_error_strings ();
#if defined HAVE_PTHREADS
- if (CRYPTO_get_locking_callback () == NULL)
+ /* OpenSSL 1.1 removed the locking functions and finally implemented
+ * its own thread safety. In this case the locking callback will
+ * return null even after we initialize it. So if we have already
+ * allocated mutexes, don't consider that a failure.
+ */
+ if ((CRYPTO_get_locking_callback () == NULL) || (s_openssl_mutexes_count > 0))
{
- assert (s_openssl_mutexes_count == 0);
/* Allocate and initialise mutexes. We will never free
these. FIXME: Is there a portable way of having a function
invoked when a solib is unloaded? -ln */