summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorvenaas <venaas>2007-02-09 12:21:44 +0000
committervenaas <venaas@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2007-02-09 12:21:44 +0000
commit7972697f22f2aac4d0364261282a5d43c0385dc3 (patch)
treee3f2331702a23dc8151cc84ea4fa5e6952a27b98
parentbe427ded4ed91db215eb2af31ff41a3b989c61ac (diff)
changes to build on NetBSD
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/trunk@54 e88ac4ed-0b26-0410-9574-a7f39faa03bf
-rw-r--r--Makefile7
-rw-r--r--radsecproxy.c3
-rw-r--r--util.c2
3 files changed, 9 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index a7982bd..b288dd2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,10 @@
CFLAGS = -g -Wall -pthread
LDFLAGS = -lssl
+OBJ = util.o
all: radsecproxy
-radsecproxy: util.o
-
+radsecproxy: $(OBJ)
+ $(CC) $(CFLAGS) $(OBJ) $(LDFLAGS) -o radsecproxy radsecproxy.c
clean:
- rm -f util.o radsecproxy
+ rm -f $(OBJ) radsecproxy
diff --git a/radsecproxy.c b/radsecproxy.c
index 85fb401..e4634bf 100644
--- a/radsecproxy.c
+++ b/radsecproxy.c
@@ -35,7 +35,10 @@
* 1 + (2 + 2 * 3) + (2 * 30) + (2 * 30) = 129 threads
*/
+#include <sys/socket.h>
+#include <netinet/in.h>
#include <netdb.h>
+#include <string.h>
#include <unistd.h>
#include <sys/time.h>
#include <libgen.h>
diff --git a/util.c b/util.c
index e4372a3..3c48e71 100644
--- a/util.c
+++ b/util.c
@@ -6,6 +6,8 @@
* copyright notice and this permission notice appear in all copies.
*/
+#include <sys/socket.h>
+#include <netinet/in.h>
#include <netdb.h>
#include <stdio.h>
#include <stdlib.h>