summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-05-08 22:18:27 +0200
committerLinus Nordberg <linus@nordberg.se>2013-05-08 22:18:27 +0200
commitb73a7432ab85d5ca8d0683166c2c7cc75553db69 (patch)
tree4a606350f10648c64e221cee351c8613d57d702a
parentf08d4effdb7fb0dbe63b73d4fa4e3310d3b3e0ca (diff)
Pass make distcheck.
-rw-r--r--lib/Makefile.am3
-rw-r--r--lib/examples/Makefile.am2
-rw-r--r--lib/radius/Makefile.am5
-rw-r--r--lib/radsecproxy/Makefile.am15
-rw-r--r--lib/tests/Makefile.am6
5 files changed, 19 insertions, 12 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 292451f..2e8401a 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -64,7 +64,8 @@ libradsec_la_SOURCES += \
util.h
EXTRA_DIST = HACKING LICENSE libradsec.spec radsec.sym
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-tls --enable-tls-psk
libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
-libradsec_la_LDFLAGS = -version-info 1:0:0 -export-symbols radsec.sym
+libradsec_la_LDFLAGS = -version-info 1:0:0 -export-symbols $(srcdir)/radsec.sym
libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT
diff --git a/lib/examples/Makefile.am b/lib/examples/Makefile.am
index bfd31e8..f300627 100644
--- a/lib/examples/Makefile.am
+++ b/lib/examples/Makefile.am
@@ -1,5 +1,5 @@
AUTOMAKE_OPTIONS = foreign
-INCLUDES = -I$(top_srcdir)/include
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
AM_CFLAGS = -Wall -Werror -g
noinst_PROGRAMS = client
diff --git a/lib/radius/Makefile.am b/lib/radius/Makefile.am
index 96bafae..c827465 100644
--- a/lib/radius/Makefile.am
+++ b/lib/radius/Makefile.am
@@ -18,6 +18,8 @@ libradsec_radius_la_SOURCES = \
static.c \
valuepair.c
+libradsec_radius_la_SOURCES += client.h
+
libradsec_radius_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H
DICTIONARIES = \
@@ -27,7 +29,7 @@ DICTIONARIES = \
share/dictionary.ukerna \
share/dictionary.abfab.ietf
-EXTRA_DIST = $(DICTIONARIES)
+EXTRA_DIST = dictionaries.c $(DICTIONARIES) common.pl convert.pl
$(top_srcdir)/include/radsec/radius.h dictionaries.c: ${DICTIONARIES} convert.pl common.pl
$(srcdir)/convert.pl ${DICTIONARIES}
@@ -38,4 +40,3 @@ clean-local:
rm -f dictionaries.c
$(libradsec_radius_la_SOURCES): $(top_srcdir)/include/radsec/radius.h
-
diff --git a/lib/radsecproxy/Makefile.am b/lib/radsecproxy/Makefile.am
index 0d4a882..962f367 100644
--- a/lib/radsecproxy/Makefile.am
+++ b/lib/radsecproxy/Makefile.am
@@ -7,12 +7,17 @@ AM_CFLAGS = -Wall -Werror -g
noinst_LTLIBRARIES = libradsec-radsecproxy.la
libradsec_radsecproxy_la_SOURCES = \
- debug.c \
- hash.c \
- list.c \
- util.c
+ debug.c debug.h \
+ gconfig.h \
+ hash.c hash.h \
+ hostport_types.h \
+ list.c list.h \
+ radmsg.h \
+ radsecproxy.h \
+ tlv11.h \
+ util.c util.h
if RS_ENABLE_TLS
libradsec_radsecproxy_la_SOURCES += \
- tlscommon.c
+ tlscommon.c tlscommon.h
endif
diff --git a/lib/tests/Makefile.am b/lib/tests/Makefile.am
index 045991a..dc15264 100644
--- a/lib/tests/Makefile.am
+++ b/lib/tests/Makefile.am
@@ -1,12 +1,12 @@
AUTOMAKE_OPTIONS = foreign
-INCLUDES = -I$(top_srcdir)/include
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
AM_CFLAGS = -Wall -Werror -g
TESTS = test-udp
check_PROGRAMS = test-udp udp-server
-test_udp_SOURCES = test-udp.c udp.c
+test_udp_SOURCES = test-udp.c udp.c udp.h
test_udp_LDADD = ../libradsec.la -lcunit -lm
-udp_server_SOURCES = udp-server.c udp.c
+udp_server_SOURCES = udp-server.c udp.c udp.h