summaryrefslogtreecommitdiff
path: root/lib/configure.ac
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-12-20 18:38:48 +0100
committerLinus Nordberg <linus@nordberg.se>2013-12-20 19:00:12 +0100
commitc9b4a492cfe93fc9563d9b2b30bcdceefee1d4bb (patch)
treef8278f0fca0f17f02228e8f1a8d0e07cbc9b73dd /lib/configure.ac
parent5871418432e1b127c760cd42a50f781d95d245fd (diff)
Detect POSIX threads at configure time and use them for OpenSSL.
Diffstat (limited to 'lib/configure.ac')
-rw-r--r--lib/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/configure.ac b/lib/configure.ac
index bab02ed..7d8bd5f 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -17,6 +17,8 @@ AC_CHECK_LIB([confuse], [cfg_init],,
AC_MSG_ERROR([required library libconfuse not found]))
AC_CHECK_LIB([event_core], [event_get_version],,
AC_MSG_ERROR([required library libevent_core not found]))
+AH_TEMPLATE([HAVE_PTHREADS], [POSIX threads are available on this system])
+AC_SEARCH_LIBS([pthread_create], [pthread], AC_DEFINE([HAVE_PTHREADS]))
# Enable-knobs.
## Enable TLS (RadSec), default on.
@@ -47,7 +49,7 @@ AM_CONDITIONAL([RS_ENABLE_TLS_PSK], [test "${enable_tls_psk+set}" = set])
# Checks for header files.
AC_CHECK_HEADERS(
[sys/time.h time.h netdb.h netinet/in.h stdint.h stdlib.h strings.h string.h \
- sys/socket.h unistd.h syslog.h sys/select.h fcntl.h arpa/inet.h])
+ sys/socket.h unistd.h syslog.h sys/select.h fcntl.h arpa/inet.h pthread.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_TYPE_SIZE_T