summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ec3ee90
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Directly append until we no longer need oneiric support
+# oneiric doesn't seem to work with this construction
+#DEB_CFLAGS_MAINT_APPEND=-pthread
+#export DEB_CFLAGS_MAINT_APPEND
+
+%:
+ dh $@ --with autoreconf --parallel
+
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-tls --enable-tls-psk CFLAGS='$(shell dpkg-buildflags --get CFLAGS) -pthread'
+