summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
Diffstat (limited to 'lib')
-rw-r--r--lib/CHANGES9
-rw-r--r--lib/HACKING6
-rw-r--r--lib/README5
-rw-r--r--lib/configure.ac2
4 files changed, 15 insertions, 7 deletions
diff --git a/lib/CHANGES b/lib/CHANGES
new file mode 100644
index 0000000..a7640e7
--- /dev/null
+++ b/lib/CHANGES
@@ -0,0 +1,9 @@
+User visible changes between 0.0.1 and 0.0.4
+
+ - TLS support is now enabled by default. Use --disable-tls to
+ disable it.
+
+ - Support for TLS-PSK has been added (--enable-tls-psk).
+
+ - The RADIUS dictionaries are now compiled into the library and are
+ no longer read from disk.
diff --git a/lib/HACKING b/lib/HACKING
index a92f0f9..57369d2 100644
--- a/lib/HACKING
+++ b/lib/HACKING
@@ -1,10 +1,10 @@
HACKING file for libradsec (in Emacs -*- org -*- mode).
-Status as of libradsec-0.0.4.dev (2013-05-06).
+Status as of libradsec-0.0.4 (2013-12-18).
* Build instructions
sh autogen.sh
-./configure #--enable-tls
+./configure
make
examples/client -r examples/client.conf blocking-tls; echo $?
@@ -37,7 +37,7 @@ examples/client -r examples/client.conf blocking-tls; echo $?
- Application chooses allocation regime.
-Note that as of 0.0.2.dev libradsec suffers from way too much focus on
+Note that as of 0.0.4 libradsec suffers from way too much focus on
the behaviour of a blocking client and is totally useless as a server.
Not only does it lack most of the functions needed for writing a
server but it also contains at least one architectural mishap which
diff --git a/lib/README b/lib/README
index 111c570..4c0d277 100644
--- a/lib/README
+++ b/lib/README
@@ -14,7 +14,7 @@ LICENSE file.
Libradsec depends on
- libconfuse
- libevent2
-- openssl (if configured with --enable-tls)
+- openssl (unless configured with --disable-tls)
To compile the library and the examples, do something like
@@ -26,8 +26,7 @@ There are a couple of options that can be used when configuring. See
./configure --help
-for the full list. Worth mentioning here is --enable-tls and
---enable-tls-psk.
+for the full list. Worth mentioning here is --enable-tls-psk.
If the preprocessor has a hard time finding some of the header files
are, try setting environment variable CPPFLAGS at configure
diff --git a/lib/configure.ac b/lib/configure.ac
index b99e8e9..1330765 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*- script for libradsec.
AC_PREREQ([2.63])
-AC_INIT([libradsec], [0.0.4.dev], [linus+libradsec@nordu.net])
+AC_INIT([libradsec], [0.0.4], [linus+libradsec@nordu.net])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR([radsec.c])
AC_CONFIG_AUX_DIR([build-aux])