summaryrefslogtreecommitdiff
path: root/radius/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'radius/tests/Makefile')
-rw-r--r--radius/tests/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/radius/tests/Makefile b/radius/tests/Makefile
new file mode 100644
index 0000000..b9d74ad
--- /dev/null
+++ b/radius/tests/Makefile
@@ -0,0 +1,25 @@
+#
+# GNU Makefile
+#
+.PHONY: all clean
+all: radattr
+
+HEADERS := ../client.h ../radius.h
+CFLAGS := -g
+
+%.o : %.c
+ $(CC) $(CFLAGS) -I.. -I. -c $<
+
+%.o: ${HEADERS}
+
+LIBS := -lcrypto -lssl
+LDFLAGS = -L.. -lnetworkradius-client
+
+../libnetworkradius-client.a:
+ @${MAKE} -C .. libnetworkradius-client.a
+
+radattr: radattr.o ../libnetworkradius-client.a
+ ${CC} ${LFDLAGS} ${LIBS} -o $@ $^
+
+clean:
+ @rm -rf *.o *.a *~