summaryrefslogtreecommitdiff
path: root/radsecproxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'radsecproxy/Makefile.am')
-rw-r--r--radsecproxy/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/radsecproxy/Makefile.am b/radsecproxy/Makefile.am
new file mode 100644
index 0000000..dc5ffc4
--- /dev/null
+++ b/radsecproxy/Makefile.am
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -Werror -g
+
+noinst_LTLIBRARIES = libradsec-radsecproxy.la
+
+libradsec_radsecproxy_la_SOURCES = \
+ debug.c debug.h \
+ gconfig.h \
+ hash.c hash.h \
+ hostport_types.h \
+ list.c list.h \
+ radmsg.h \
+ radsecproxy.h \
+ tlv11.h \
+ util.c util.h
+
+if RS_ENABLE_TLS
+libradsec_radsecproxy_la_SOURCES += \
+ tlscommon.c tlscommon.h
+endif