summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..09f9d28
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,12 @@
+AUTOMAKE_OPTIONS = foreign
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -Werror -g
+
+TESTS = test-udp
+
+check_PROGRAMS = test-udp udp-server
+
+test_udp_SOURCES = test-udp.c udp.c udp.h
+test_udp_LDADD = ../libradsec.la -lcunit -lm
+
+udp_server_SOURCES = udp-server.c udp.c udp.h