summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Seligmann <mithrandi@mithrandi.net>2015-08-07 20:45:35 +0200
committerTristan Seligmann <mithrandi@mithrandi.net>2015-08-07 20:45:35 +0200
commit02d32dba04527826692af639205c8e2d4bebe314 (patch)
tree53094b5baae21a6575116bb5a95300d2babbeffb
parent8da763be1cf5530306fdf82547561ccbcdfe1628 (diff)
Fix quilt stuff.
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4708a9d..05eeea6 100644
--- a/Makefile
+++ b/Makefile
@@ -5,8 +5,8 @@ MAKE_DIR ?= install -d
INSTALL_DATA ?= install
CC?=gcc
-CFLAGS += -Wall -fPIC
-LDFLAGS += -Wl,-z,now -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
+CFLAGS?=-O2 -Wall -g -D_FORTIFY_SOURCE=2 -fstack-protector -fPIC
+LDFLAGS?=-Wl,-z,now -Wl,-z,relro -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
CFLAGS_EXTRA?=-Wl,-rpath=.
all: reference