summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2015-05-08 21:48:29 +0100
committerJames Cowgill <james410@cowgill.org.uk>2015-05-09 00:50:56 +0100
commit545a437f592c6a8aa3c8b5262b7ff93f93041df9 (patch)
tree3ff93d6ecf94eb30f1784a6b9bc6c3fecbe75c4c
parent493bc6127f65aa502715468aaa79ad715052e791 (diff)
Refresh patches, drop 01_fix-gl-headers - no longer needed
-rw-r--r--debian/patches/01_fix-gl-headers.patch15
-rw-r--r--debian/patches/02_hurd.patch12
-rw-r--r--debian/patches/04_remove-googleapi-css.patch15
-rw-r--r--debian/patches/05_build-doc-once.patch2
-rw-r--r--debian/patches/series1
5 files changed, 14 insertions, 31 deletions
diff --git a/debian/patches/01_fix-gl-headers.patch b/debian/patches/01_fix-gl-headers.patch
deleted file mode 100644
index c427881..0000000
--- a/debian/patches/01_fix-gl-headers.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Description: Use glext.h from libgl1-mesa-dev
-Author: James Cowgill <james410@cowgill.org.uk>
----
-This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/src/SFML/Window/GlContext.cpp
-+++ b/src/SFML/Window/GlContext.cpp
-@@ -35,7 +35,7 @@
- #ifdef SFML_SYSTEM_IOS
- #include <OpenGLES/ES1/gl.h>
- #else
-- #include <SFML/Window/glext/glext.h>
-+ #include <GL/glext.h>
- #endif
-
- #if !defined(SFML_OPENGL_ES)
diff --git a/debian/patches/02_hurd.patch b/debian/patches/02_hurd.patch
index c10adc3..3b7775e 100644
--- a/debian/patches/02_hurd.patch
+++ b/debian/patches/02_hurd.patch
@@ -38,8 +38,8 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
// Unsupported UNIX system
--- a/src/SFML/Window/CMakeLists.txt
+++ b/src/SFML/Window/CMakeLists.txt
-@@ -86,7 +86,13 @@ elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD)
- ${SRCROOT}/Unix/GlxContext.hpp
+@@ -92,7 +92,13 @@ elseif(SFML_OS_LINUX OR SFML_OS_FREEBSD)
+ ${SRCROOT}/Unix/GlxExtensions.hpp
)
endif()
- if(SFML_OS_LINUX)
@@ -53,7 +53,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
set(PLATFORM_SRC
${PLATFORM_SRC}
${SRCROOT}/Unix/JoystickImpl.cpp
-@@ -205,7 +211,7 @@ if(SFML_OPENGL_ES AND SFML_OS_LINUX)
+@@ -211,7 +217,7 @@ if(SFML_OPENGL_ES AND SFML_OS_LINUX)
find_package(GLES REQUIRED)
include_directories(${EGL_INCLUDE_DIR} ${GLES_INCLUDE_DIR})
endif()
@@ -62,14 +62,14 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
find_package(UDev REQUIRED)
if(NOT UDEV_FOUND)
message(FATAL_ERROR "udev library not found")
-@@ -217,6 +223,8 @@ endif()
+@@ -223,6 +229,8 @@ endif()
# build the list of external libraries to link
if(SFML_OS_WINDOWS)
list(APPEND WINDOW_EXT_LIBS winmm gdi32)
+elseif(SFML_OS_HURD)
-+ list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${X11_Xrandr_LIB})
++ list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${LIBXCB_LIBRARIES})
elseif(SFML_OS_LINUX)
- list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${X11_Xrandr_LIB} ${UDEV_LIBRARIES})
+ list(APPEND WINDOW_EXT_LIBS ${X11_X11_LIB} ${LIBXCB_LIBRARIES} ${UDEV_LIBRARIES})
elseif(SFML_OS_FREEBSD)
--- /dev/null
+++ b/src/SFML/Window/Dummy/JoystickImpl.cpp
diff --git a/debian/patches/04_remove-googleapi-css.patch b/debian/patches/04_remove-googleapi-css.patch
index c72d61e..6afea4d 100644
--- a/debian/patches/04_remove-googleapi-css.patch
+++ b/debian/patches/04_remove-googleapi-css.patch
@@ -2,16 +2,15 @@ Description: Remove commented out googleapi css in documentation
There isn't actually any privacy breach here (since the line is commented
out), but removing it shuts up lintian.
Author: James Cowgill <james410@cowgill.org.uk>
-Last-Update: 2014-05-07
---
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
---- a/doc/header.htm
-+++ b/doc/header.htm
-@@ -3,7 +3,6 @@
- <head>
+--- a/doc/header.html.in
++++ b/doc/header.html.in
+@@ -4,7 +4,6 @@
<title>SFML - Simple and Fast Multimedia Library</title>
- <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
+ <meta http-equiv="Content-Type" content="text/html;"/>
+ <meta charset="utf-8"/>
- <!--<link rel='stylesheet' type='text/css' href="http://fonts.googleapis.com/css?family=Ubuntu:400,700,400italic"/>-->
<link rel="stylesheet" type="text/css" href="doxygen.css" title="default" media="screen,print" />
- </head>
- <body>
+ <script type="text/javascript" src="jquery.js"></script>
+ <script type="text/javascript" src="dynsections.js"></script>
diff --git a/debian/patches/05_build-doc-once.patch b/debian/patches/05_build-doc-once.patch
index fe94b46..71bc68b 100644
--- a/debian/patches/05_build-doc-once.patch
+++ b/debian/patches/05_build-doc-once.patch
@@ -10,7 +10,7 @@ Forwarded: no
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
-@@ -44,7 +44,7 @@ configure_file(${DOXYGEN_INPUT_DIR}/doc/
+@@ -45,7 +45,7 @@ configure_file(${DOXYGEN_INPUT_DIR}/doc/
configure_file(${DOXYGEN_INPUT_DIR}/doc/doxygen.css ${DOXYGEN_OUTPUT_DIR}/html/doxygen.css COPYONLY)
# target setup
diff --git a/debian/patches/series b/debian/patches/series
index 95b81d6..ffbf3a8 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,3 @@
-01_fix-gl-headers.patch
02_hurd.patch
04_remove-googleapi-css.patch
05_build-doc-once.patch