summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJames Cowgill <jcowgill@debian.org>2016-08-09 15:44:45 +0000
committerJames Cowgill <jcowgill@debian.org>2016-08-09 15:44:45 +0000
commit0273918ec2c39f537c9d25ca50363f25722d652c (patch)
tree670bb2cfc798dcccb8941fc146a6c110a4f93f91 /debian/rules
parente27fd6a7be1f0d82dc2139dae11bd707bc998994 (diff)
Drop the symbols files
Maintaining the symbols files for a C++ library is a massive PITA. Upstream bumps the SONAME and breaks the ABI enough times that the symbols files have no real benefit (the important information is already encoded in the package name). Upstream is also pretty good about not making any important API changes during patch releases. For these reasons I'm removing the symbols files. dh_makeshlibs -V can still be used in the unlikely event upstream adds a new function during a patch release.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f0c130d..9f1b425 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
- dh $@ --parallel --with pkgkde_symbolshelper
+ dh $@ --parallel
override_dh_auto_configure:
dh_auto_configure -- -DLIB_SUFFIX=/$(DEB_HOST_MULTIARCH) -DSFML_BUILD_DOC=ON -DSFML_INSTALL_PKGCONFIG_FILES=ON