summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristoph Egger <Christoph.Egger@gmx.de>2009-07-25 14:03:58 +0200
committerChristoph Egger <Christoph.Egger@gmx.de>2009-07-25 14:03:58 +0200
commit3f1e84d7625801077fcf7fc730b0e9df9f562819 (patch)
tree8dd6fb5720d30c9b4e1ffa60644dcbae4c20a83b /debian/rules
parent06d16b47412b8add03b6334d7383371978c76f72 (diff)
Fix get-orig-source target
Clean up commented-out superseeded code Imporove make clean
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 1c567f5..e5aa3ef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,22 +17,21 @@ get-orig-source:
wget http://downloads.sourceforge.net/sfml/SFML-1.5-sdk-linux-32.tar.gz ; \
tar -xzf SFML-1.5-sdk-linux-32.tar.gz ; cd SFML-1.5 ; \
find . \( -iname glew -o -iname glext -o -iname libjpeg \
- -o -iname libpng -o -iname zlib -o -iname SOIL \) -delete \
+ -o -iname libpng -o -iname zlib -o -iname SOIL \) -print | xargs /bin/rm -rf ; \
find samples \( -name "*.jpg" -o -name "*.png" -o -name "*.[ch]pp" -o \
- -name "*.sfx" \) -print | xargs /bin/chmod a-x ;
+ -name "*.sfx" \) -print | xargs /bin/chmod a-x ; \
make mrproper ; \
cd .. ; rm SFML-1.5-sdk-linux-32.tar.gz; mv SFML-1.5/* . ; rm -r SFML-1.5
- cd .. ; dpkg-source -b -su libsfml libsfml-1.5.orig
+ cd .. ; dpkg-source -b -i -su libsfml libsfml-1.5.orig
build: build-stamp
build-stamp: $(QUILT_STAMPFN)
dh_testdir
- -mkdir lib
+ [ -d lib ] || mkdir lib
$(MAKE) sfml
touch $@
clean: unpatch
- #find lib -name "*so*" -exec rm {} \;
dh_testdir
dh_testroot