summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristoph Egger <Christoph.Egger@gmx.de>2009-08-27 01:14:57 +0200
committerChristoph Egger <Christoph.Egger@gmx.de>2009-08-27 01:14:57 +0200
commit4f929d8f63d1f47c27a030f84ff95eeb275b8a68 (patch)
treeee76be060d0a08637914e4af07c3cc7f9df451fc /debian/rules
parent88e885c918b340f3dabde2642498deda29198a3d (diff)
New changelog + cleanup
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 7 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 2540bc4..36145fa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,24 +5,23 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
-version=1.5.0
+version=1.5
major=1
include /usr/share/quilt/quilt.make
-include /usr/share/topgit/tg2quilt.mk
get-orig-source:
- cd .. ; rm -rf libsfml-1.5.orig ; mkdir libsfml-1.5.orig ; cd libsfml-1.5.orig ; \
- wget http://downloads.sourceforge.net/sfml/SFML-1.5-sdk-linux-32.tar.gz ; \
- tar -xzf SFML-1.5-sdk-linux-32.tar.gz ; cd SFML-1.5 ; \
+ cd .. ; rm -rf libsfml-$(version).orig ; mkdir libsfml-$(version).orig ; cd libsfml-$(version).orig ; \
+ wget http://downloads.sourceforge.net/sfml/SFML-$(version)-sdk-linux-32.tar.gz ; \
+ tar -xzf SFML-$(version)-sdk-linux-32.tar.gz ; cd SFML-$(version) ; \
find . \( -iname glew -o -iname glext -o -iname libjpeg \
-o -iname libpng -o -iname zlib -o -iname SOIL \) -print | xargs /bin/rm -rf ; \
find samples \( -name "*.jpg" -o -name "*.png" -o -name "*.[ch]pp" -o \
-name "*.sfx" \) -print | xargs /bin/chmod a-x ; \
make mrproper ; \
- cd .. ; rm SFML-1.5-sdk-linux-32.tar.gz; mv SFML-1.5/* . ; rm -r SFML-1.5
- cd .. ; dpkg-source -b -i -su libsfml libsfml-1.5.orig
+ cd .. ; rm SFML-$(version)-sdk-linux-32.tar.gz; mv SFML-$(version)/* . ; rm -r SFML-$(version)
+ cd .. ; dpkg-source -b -i -su libsfml libsfml-$(version).orig
build: build-stamp
build-stamp: $(QUILT_STAMPFN)
@@ -43,7 +42,7 @@ clean: unpatch
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_prep
dh_installdirs
$(MAKE) DESTDIR=$(CURDIR)/debian/tmp/usr install