summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2013-10-01 21:55:42 +0100
committerJames Cowgill <james410@cowgill.org.uk>2013-10-01 21:55:42 +0100
commit932e5b3035e0f575c9f93004f261657a60d44296 (patch)
tree62321f85a578dc6d0b2efd94b99602bce0671e27 /debian/rules
parentf48dd693b4cb6123cdeef10d98c421d9b584f77b (diff)
Added --as-needed linker option to only build against needed libraries
This suppresses the "dpkg-shlibdeps: warning: package could avoid a useless dependency if" warnings. It also reduces the amount of dependencies needed (especially in libsfml-graphics2)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 49a8f04..bdf2475 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,9 @@ VER ?= $(subst $(DTYPE),,$(UVER))
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# Only link libraries that are actually needed
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
%:
dh $@