summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristoph Egger <Christoph.Egger@gmx.de>2009-06-16 12:08:15 +0200
committerChristoph Egger <Christoph.Egger@gmx.de>2009-06-16 12:08:15 +0200
commita8385bb87a29345f529db7e6d13d8bf1e6c74c99 (patch)
tree0f9defc8d2584f63fb3e7a1023077082a52b9fc4 /debian/rules
parent7f7747805f3c025b6a97133cdbfa93bc05201e6f (diff)
last polishing
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 356d632..fd0ca2c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,7 +19,8 @@ get-orig-source:
find . \( -iname glew -o -iname glext -o -iname libjpeg \
-o -iname libpng -o -iname zlib -o -iname SOIL \) -print | xargs /bin/rm -rf ; \
find samples \( -name "*.jpg" -o -name "*.png" -o -name "*.[ch]pp" -o \
- -name "*.sfx" \) -print | xargs /bin/chmod a-x ; \
+ -name "*.sfx" \) -print | xargs /bin/chmod a-x ;
+ make mrproper ; \
cd .. ; rm SFML-1.5-sdk-linux-32.tar.gz; mv SFML-1.5/* . ; rm -r SFML-1.5
cd .. ; dpkg-source -b -su libsfml libsfml-1.5.orig
@@ -69,7 +70,7 @@ binary-arch: build install
dh_testroot
dh_installchangelogs
dh_installdocs
- dh_installexamples ;# ( cd debian/libsfml1.5-doc/usr/share/doc/libsfml1.4-doc/examples/ && make clean && chmod -R a-x .)
+ dh_installexamples
dh_install --fail-missing --sourcedir=debian/tmp
dh_installman
dh_link