summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristoph Egger <Christoph.Egger@gmx.de>2009-07-11 16:01:03 +0200
committerChristoph Egger <Christoph.Egger@gmx.de>2009-07-11 16:01:03 +0200
commitad09845833d0dad402b665ef2694807822561f66 (patch)
treee56ed17970d6268346453c7e1acf70f1824ba551 /debian/rules
parenta8385bb87a29345f529db7e6d13d8bf1e6c74c99 (diff)
Some minor debian/rules improvments suggested by Sandro Tosi
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 2 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index fd0ca2c..1c567f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,22 +17,15 @@ get-orig-source:
wget http://downloads.sourceforge.net/sfml/SFML-1.5-sdk-linux-32.tar.gz ; \
tar -xzf SFML-1.5-sdk-linux-32.tar.gz ; cd SFML-1.5 ; \
find . \( -iname glew -o -iname glext -o -iname libjpeg \
- -o -iname libpng -o -iname zlib -o -iname SOIL \) -print | xargs /bin/rm -rf ; \
+ -o -iname libpng -o -iname zlib -o -iname SOIL \) -delete \
find samples \( -name "*.jpg" -o -name "*.png" -o -name "*.[ch]pp" -o \
-name "*.sfx" \) -print | xargs /bin/chmod a-x ;
make mrproper ; \
cd .. ; rm SFML-1.5-sdk-linux-32.tar.gz; mv SFML-1.5/* . ; rm -r SFML-1.5
cd .. ; dpkg-source -b -su libsfml libsfml-1.5.orig
-configure: configure-stamp
-configure-stamp: $(QUILT_STAMPFN)
- dh_testdir
-
- touch configure-stamp
-
-
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: $(QUILT_STAMPFN)
dh_testdir
-mkdir lib
$(MAKE) sfml