summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2014-12-09 19:57:29 +0000
committerJames Cowgill <james410@cowgill.org.uk>2014-12-09 20:02:47 +0000
commitb10edf9906b816fc9f26383d7ccf55dbbbadcf20 (patch)
tree1e96445d9aec35ca549e1aefb0cb7d07c1964bef /debian/rules
parentdf47139e8bf1ff536fb9e9e2c5b160b594f8dc36 (diff)
Use --download-cuurent-version from recent uscan
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 2 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 0f14b10..823402a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,7 @@
#!/usr/bin/make -f
# -*- makefile -*-
-PKD = $(abspath $(dir $(MAKEFILE_LIST)))
-PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
-UVER = $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\-\d+.*)};')
-DTYPE = +dfsg2
-VER ?= $(subst $(DTYPE),,$(UVER))
-
+PKD = $(abspath $(dir $(MAKEFILE_LIST)))
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -24,4 +19,4 @@ override_dh_strip:
.PHONY: get-orig-source
## http://wiki.debian.org/onlyjob/get-orig-source
get-orig-source:
- uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --repack --compression=xz --upstream-version $(VER) $(PKD)
+ uscan --noconf --verbose --rename --destdir=$(CURDIR) --check-dirname-level=0 --force-download --repack --compression=xz --download-current-version $(PKD)