summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2014-05-06 23:10:27 +0100
committerJames Cowgill <james410@cowgill.org.uk>2014-05-06 23:10:27 +0100
commitfdde9cc647eb326bd0bc2de5e2d0e0690ba0adc5 (patch)
tree7554670f88c8429e8c9adbaeea19b8d365cc4e02 /debian/rules
parent33a269f593fa20298f6e19d897c4ead8be9e8c27 (diff)
Enable all hardening flags
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 1 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 1916e0e..e809db5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,6 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
PKD = $(abspath $(dir $(MAKEFILE_LIST)))
PKG = $(word 2,$(shell dpkg-parsechangelog -l$(PKD)/changelog | grep ^Source))
UVER = $(shell dpkg-parsechangelog -l$(PKD)/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\-\d+.*)};')
@@ -12,7 +9,7 @@ VER ?= $(subst $(DTYPE),,$(UVER))
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-# Only link libraries that are actually needed
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%: