summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/compat2
-rwxr-xr-xdebian/rules8
-rw-r--r--debian/watch21
3 files changed, 8 insertions, 23 deletions
diff --git a/debian/compat b/debian/compat
index 7ed6ff8..7f8f011 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-5
+7
diff --git a/debian/rules b/debian/rules
index e5aa3ef..2540bc4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,7 +27,7 @@ get-orig-source:
build: build-stamp
build-stamp: $(QUILT_STAMPFN)
dh_testdir
- [ -d lib ] || mkdir lib
+ mkdir -p lib
$(MAKE) sfml
touch $@
@@ -38,9 +38,7 @@ clean: unpatch
# Add here commands to clean up after the build process.
$(MAKE) mrproper
- rm -Rf .pc
-
- dh_clean build-stamp configure-stamp
+ dh_clean
install: build
dh_testdir
@@ -78,4 +76,4 @@ binary-arch: build install
dh_builddeb
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/watch b/debian/watch
index d473026..7a6a7e4 100644
--- a/debian/watch
+++ b/debian/watch
@@ -1,22 +1,9 @@
-# Example watch control file for uscan
-# Rename this file to "watch" and then you can run the "uscan" command
-# to check for upstream updates and more.
# See uscan(1) for format
-
-# Compulsory line, this is a version 3 file
version=3
-# Uncomment to examine a Webpage
-# <Webpage URL> <string match>
-#http://www.sfml-dev.org/download.php http://downloads.sourceforge.net/sfml/SFML-([\d\.]*\d)-sdk-linux\.tar\.gz
-
-# Uncomment to examine a Webserver directory
-#http://www.example.com/pub/libsfml-(.*)\.tar\.gz
-
-# Uncommment to examine a FTP server
-#ftp://ftp.example.com/pub/libsfml-(.*)\.tar\.gz debian uupdate
-
-# Uncomment to find new files on sourceforge, for devscripts >= 2.9
-http://sf.net/sfml/SFML-([\d\.]*\d)-sdk-linux\.tar\.gz
+opts=dversionmangle=s/\+repack\d+$//g \
+ http://www.sfml-dev.org/download.php http://downloads.sourceforge.net/sfml/SFML-([\d\.]*\d)-sdk-linux-32\.tar\.gz
+#opts=dversionmangle=s/\+repack\d+$//g \
+# http://sf.net/sfml/SFML-([\d\.]*\d)-sdk-linux\.tar\.gz