summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/tests/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/tests/CMakeLists.txt b/debian/tests/CMakeLists.txt
index d5683fa..02c726b 100644
--- a/debian/tests/CMakeLists.txt
+++ b/debian/tests/CMakeLists.txt
@@ -3,11 +3,10 @@
cmake_minimum_required(VERSION 2.8)
project(SFMLTest CXX)
-# Try to find SFML using Debian modules directory
-list(APPEND CMAKE_MODULE_PATH "/usr/share/SFML/cmake/Modules")
-find_package(SFML 2 COMPONENTS network system REQUIRED MODULE)
+# Try to find SFML using CMake config file
+# Even though this test doesn't need them, request all components to check they exist
+find_package(SFML 2 COMPONENTS audio graphics network system window REQUIRED CONFIG)
# Build the exexutable
-include_directories(${SFML_INCLUDE_DIR})
add_executable(sfml_test sfml_test.cpp)
-target_link_libraries(sfml_test ${SFML_LIBRARIES})
+target_link_libraries(sfml_test sfml-network sfml-system)