summaryrefslogtreecommitdiff
path: root/debian/patches/03_pkgconfig-cleanup.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/03_pkgconfig-cleanup.patch')
-rw-r--r--debian/patches/03_pkgconfig-cleanup.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/debian/patches/03_pkgconfig-cleanup.patch b/debian/patches/03_pkgconfig-cleanup.patch
new file mode 100644
index 0000000..915bae0
--- /dev/null
+++ b/debian/patches/03_pkgconfig-cleanup.patch
@@ -0,0 +1,41 @@
+Description: Cleanup duplicated pkg-config code
+ Some parts of the pkg-config code released with 2.5.0 were duplicated and make
+ adjusting the pkg-config paths more complicated. Fix this by simply removing
+ the old code (which should be removed anyway).
+Author: James Cowgill <jcowgill@debian.org>
+Forwarded: no
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -269,30 +269,6 @@ if(SFML_OS_MACOSX)
+ set(XCODE_TEMPLATES_ARCH "\$(NATIVE_ARCH_ACTUAL)")
+ endif()
+
+-if(SFML_OS_LINUX OR SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
+- set(PKGCONFIG_DIR lib${LIB_SUFFIX}/pkgconfig)
+- if(SFML_OS_FREEBSD OR SFML_OS_OPENBSD)
+- set(PKGCONFIG_DIR libdata/pkgconfig)
+- endif()
+- if(BUILD_SHARED_LIBS)
+- sfml_set_option(SFML_INSTALL_PKGCONFIG_FILES FALSE BOOL "TRUE to automatically install pkg-config files so other projects can find SFML")
+- if(SFML_INSTALL_PKGCONFIG_FILES)
+- foreach(sfml_module IN ITEMS all system window graphics audio network)
+- CONFIGURE_FILE(
+- "tools/pkg-config/sfml-${sfml_module}.pc.in"
+- "tools/pkg-config/sfml-${sfml_module}.pc"
+- @ONLY)
+- INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/tools/pkg-config/sfml-${sfml_module}.pc"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/${PKGCONFIG_DIR}")
+- endforeach()
+- endif()
+- else()
+- if(SFML_INSTALL_PKGCONFIG_FILES)
+- message(WARNING "No pkg-config files are provided for the static SFML libraries (SFML_INSTALL_PKGCONFIG_FILES will be ignored).")
+- endif()
+- endif()
+-endif()
+-
+ # enable project folders
+ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
+ set_property(GLOBAL PROPERTY PREDEFINED_TARGETS_FOLDER "CMake")