summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/fix-includes.diff38
-rw-r--r--debian/patches/debian/gcc-4.6.diff142
-rw-r--r--debian/patches/debian/gcc-4.7.diff26
-rw-r--r--debian/patches/debian/interlinking.diff78
-rw-r--r--debian/patches/debian/kfreebsd.diff27
-rw-r--r--debian/patches/debian/libpng-1.5.diff42
-rw-r--r--debian/patches/debian/remove-Arial.hpp23
-rw-r--r--debian/patches/debian/repacking.diff132
-rw-r--r--debian/patches/debian/scriptheader-in-example-makefiles.diff157
-rw-r--r--debian/patches/series9
10 files changed, 0 insertions, 674 deletions
diff --git a/debian/patches/debian/fix-includes.diff b/debian/patches/debian/fix-includes.diff
deleted file mode 100644
index 83ef833..0000000
--- a/debian/patches/debian/fix-includes.diff
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Christoph Egger <christoph@debian.org>
-Subject: [PATCH] debian/fix-includes
-
-SFML needs sme modified includes to build against gcc-4.6
-
-Signed-off-by: Christoph Egger <christoph@debian.org>
-
----
- include/SFML/System/Resource.hpp | 1 +
- include/SFML/System/ResourcePtr.inl | 1 +
- 2 files changed, 2 insertions(+)
-
-diff --git a/include/SFML/System/Resource.hpp b/include/SFML/System/Resource.hpp
-index 8f5088d..db651b0 100755
---- a/include/SFML/System/Resource.hpp
-+++ b/include/SFML/System/Resource.hpp
-@@ -29,6 +29,7 @@
- // Headers
- ////////////////////////////////////////////////////////////
- #include <set>
-+#include <cstddef>
-
-
- namespace sf
-diff --git a/include/SFML/System/ResourcePtr.inl b/include/SFML/System/ResourcePtr.inl
-index dbfcd0d..7bda5f1 100755
---- a/include/SFML/System/ResourcePtr.inl
-+++ b/include/SFML/System/ResourcePtr.inl
-@@ -22,6 +22,7 @@
- //
- ////////////////////////////////////////////////////////////
-
-+#include <cstddef>
-
- ////////////////////////////////////////////////////////////
- /// Default constructor
---
-tg: (755caaf..) debian/fix-includes (depends on: debian/scriptheader-in-example-makefiles)
diff --git a/debian/patches/debian/gcc-4.6.diff b/debian/patches/debian/gcc-4.6.diff
deleted file mode 100644
index d3c541b..0000000
--- a/debian/patches/debian/gcc-4.6.diff
+++ /dev/null
@@ -1,142 +0,0 @@
-From: Evgeni Golov <evgeni@debian.org>
-Subject: [PATCH] debian/gcc-4.6
-
-Properly link with GCC 4.6.
-#include <cstddef> everywhere.
-Closes: #625031
-
-Signed-off-by: Evgeni Golov <evgeni@debian.org>
-
----
- include/SFML/Audio/Music.hpp | 1 +
- include/SFML/Audio/Sound.hpp | 1 +
- include/SFML/Audio/SoundBuffer.hpp | 1 +
- include/SFML/Graphics/PostFX.hpp | 1 +
- include/SFML/Graphics/RenderWindow.hpp | 1 +
- include/SFML/Graphics/Sprite.hpp | 1 +
- include/SFML/Graphics/String.hpp | 1 +
- include/SFML/System/ResourcePtr.inl | 1 +
- src/SFML/Graphics/Font.cpp | 1 +
- src/SFML/Graphics/Image.cpp | 1 +
- 10 files changed, 10 insertions(+)
-
-Index: libsfml/include/SFML/Audio/Music.hpp
-===================================================================
---- libsfml.orig/include/SFML/Audio/Music.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Audio/Music.hpp 2012-07-08 21:07:39.650370721 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/Audio/SoundStream.hpp>
- #include <string>
- #include <vector>
-Index: libsfml/include/SFML/Audio/Sound.hpp
-===================================================================
---- libsfml.orig/include/SFML/Audio/Sound.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Audio/Sound.hpp 2012-07-08 21:07:39.650370721 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/System/Resource.hpp>
- #include <SFML/System/Vector3.hpp>
- #include <SFML/Audio/AudioResource.hpp>
-Index: libsfml/include/SFML/Audio/SoundBuffer.hpp
-===================================================================
---- libsfml.orig/include/SFML/Audio/SoundBuffer.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Audio/SoundBuffer.hpp 2012-07-08 21:07:39.650370721 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/System/Resource.hpp>
- #include <SFML/Audio/AudioResource.hpp>
- #include <string>
-Index: libsfml/include/SFML/Graphics/PostFX.hpp
-===================================================================
---- libsfml.orig/include/SFML/Graphics/PostFX.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Graphics/PostFX.hpp 2012-07-08 21:07:39.660371117 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/Graphics/Drawable.hpp>
- #include <SFML/Graphics/Image.hpp>
- #include <istream>
-Index: libsfml/include/SFML/Graphics/RenderWindow.hpp
-===================================================================
---- libsfml.orig/include/SFML/Graphics/RenderWindow.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Graphics/RenderWindow.hpp 2012-07-08 21:07:39.660371117 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/Graphics/Image.hpp>
- #include <SFML/Graphics/RenderTarget.hpp>
- #include <SFML/Window/Window.hpp>
-Index: libsfml/include/SFML/Graphics/Sprite.hpp
-===================================================================
---- libsfml.orig/include/SFML/Graphics/Sprite.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Graphics/Sprite.hpp 2012-07-08 21:07:39.660371117 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/System/Resource.hpp>
- #include <SFML/Graphics/Drawable.hpp>
- #include <SFML/Graphics/Rect.hpp>
-Index: libsfml/include/SFML/Graphics/String.hpp
-===================================================================
---- libsfml.orig/include/SFML/Graphics/String.hpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/Graphics/String.hpp 2012-07-08 21:07:39.660371117 +0200
-@@ -28,6 +28,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/System/Resource.hpp>
- #include <SFML/System/Unicode.hpp>
- #include <SFML/Graphics/Drawable.hpp>
-Index: libsfml/include/SFML/System/ResourcePtr.inl
-===================================================================
---- libsfml.orig/include/SFML/System/ResourcePtr.inl 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/include/SFML/System/ResourcePtr.inl 2012-07-08 21:07:39.660371117 +0200
-@@ -34,6 +34,7 @@
-
- }
-
-+#include <cstddef>
-
- ////////////////////////////////////////////////////////////
- /// Construct from a raw resource
-Index: libsfml/src/SFML/Graphics/Font.cpp
-===================================================================
---- libsfml.orig/src/SFML/Graphics/Font.cpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/src/SFML/Graphics/Font.cpp 2012-07-08 21:07:39.660371117 +0200
-@@ -25,6 +25,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/Graphics/Font.hpp>
- #include <SFML/Graphics/FontLoader.hpp>
- #include <iostream>
-Index: libsfml/src/SFML/Graphics/Image.cpp
-===================================================================
---- libsfml.orig/src/SFML/Graphics/Image.cpp 2012-07-08 21:07:35.000000000 +0200
-+++ libsfml/src/SFML/Graphics/Image.cpp 2012-07-08 21:07:39.660371117 +0200
-@@ -25,6 +25,7 @@
- ////////////////////////////////////////////////////////////
- // Headers
- ////////////////////////////////////////////////////////////
-+#include <cstddef>
- #include <SFML/Graphics/Image.hpp>
- #include <SFML/Graphics/ImageLoader.hpp>
- #include <SFML/Graphics/RenderWindow.hpp>
diff --git a/debian/patches/debian/gcc-4.7.diff b/debian/patches/debian/gcc-4.7.diff
deleted file mode 100644
index c72ab99..0000000
--- a/debian/patches/debian/gcc-4.7.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Matthias Klose <doko@debian.org>
-Subject: [PATCH] debian/gcc-4.7
-
-Fix build failure with GCC 4.7. Closes: #672086.
-
-Signed-off-by: Dmitrijs Ledkovs <xnox@debian.org>
-Signed-off-by: Matthias Klose <doko@debian.org>
-
----
- src/SFML/Window/Linux/Joystick.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/SFML/Window/Linux/Joystick.cpp b/src/SFML/Window/Linux/Joystick.cpp
-index 829a741..c2dabf2 100755
---- a/src/SFML/Window/Linux/Joystick.cpp
-+++ b/src/SFML/Window/Linux/Joystick.cpp
-@@ -27,6 +27,7 @@
- ////////////////////////////////////////////////////////////
- #include <SFML/Window/Joystick.hpp>
- #include <sstream>
-+#include <unistd.h>
-
-
- namespace sf
---
-tg: (afb79c7..) debian/gcc-4.7 (depends on: master)
diff --git a/debian/patches/debian/interlinking.diff b/debian/patches/debian/interlinking.diff
deleted file mode 100644
index 4b19c68..0000000
--- a/debian/patches/debian/interlinking.diff
+++ /dev/null
@@ -1,78 +0,0 @@
-From: Christoph Egger <Christoph.Egger@gmx.de>
-Subject: [PATCH] debian/interlinking
-
- Some of the SFML libraries depend on each other but they are currently not
-linked against them. This patch fixes this issue.
-
-Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
-
----
- src/SFML/Audio/Makefile | 2 +-
- src/SFML/Graphics/Makefile | 2 +-
- src/SFML/Makefile | 4 ++--
- src/SFML/Window/Makefile | 2 +-
- 4 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/SFML/Audio/Makefile b/src/SFML/Audio/Makefile
-index 0215e80..175bb61 100755
---- a/src/SFML/Audio/Makefile
-+++ b/src/SFML/Audio/Makefile
-@@ -19,7 +19,7 @@ libsfml-audio-s.a: $(OBJ) $(OBJVORBIS)
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ) $(OBJVORBIS)
-
- libsfml-audio.so: $(OBJ) $(OBJVORBIS)
-- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJVORBIS) -lsndfile -lopenal
-+ $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJVORBIS) -lsndfile -lopenal $(LIBPATH)/libsfml-system.so.$(VERSION)
-
- $(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS)
-diff --git a/src/SFML/Graphics/Makefile b/src/SFML/Graphics/Makefile
-index 4de224d..f149155 100755
---- a/src/SFML/Graphics/Makefile
-+++ b/src/SFML/Graphics/Makefile
-@@ -27,7 +27,7 @@ libsfml-graphics-s.a: $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLI
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
-
- libsfml-graphics.so: $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
-- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB) -lfreetype -lX11 -lGL
-+ $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB) -lfreetype $(LIBPATH)/libsfml-system.so.$(VERSION) $(LIBPATH)/libsfml-window.so.$(VERSION) -lGL
-
- $(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS) -I/usr/include/freetype2
-diff --git a/src/SFML/Makefile b/src/SFML/Makefile
-index d8f633e..cd73816 100755
---- a/src/SFML/Makefile
-+++ b/src/SFML/Makefile
-@@ -37,7 +37,7 @@ sfml-system:
- @(mkdir -p ../../lib)
- @(cd ./System && $(MAKE))
-
--sfml-window:
-+sfml-window: sfml-system
- @(mkdir -p ../../lib)
- @(cd ./Window && $(MAKE))
-
-@@ -45,7 +45,7 @@ sfml-network:
- @(mkdir -p ../../lib)
- @(cd ./Network && $(MAKE))
-
--sfml-graphics:
-+sfml-graphics: sfml-system sfml-window
- @(mkdir -p ../../lib)
- @(cd ./Graphics && $(MAKE))
-
-diff --git a/src/SFML/Window/Makefile b/src/SFML/Window/Makefile
-index 0dd689c..a05a54b 100755
---- a/src/SFML/Window/Makefile
-+++ b/src/SFML/Window/Makefile
-@@ -18,7 +18,7 @@ libsfml-window-s.a: $(OBJ)
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ)
-
- libsfml-window.so: $(OBJ)
-- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) -lX11 -lXrandr -lGL
-+ $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) -lX11 -lXrandr -lGL $(LIBPATH)/libsfml-system.so.$(VERSION)
-
- $(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS)
---
-tg: (9b1ef37..) debian/interlinking (depends on: debian/destdir-install-symlinks)
diff --git a/debian/patches/debian/kfreebsd.diff b/debian/patches/debian/kfreebsd.diff
deleted file mode 100644
index e22e2a4..0000000
--- a/debian/patches/debian/kfreebsd.diff
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Christoph Egger <Christoph.Egger@gmx.de>
-Subject: [PATCH] debian/kfreebsd
-
-This patch gets GNU/kFreeBSD handled as FreeBSD and therefor enables
-building on Debian GNU/kFreeBSD. The same should work on GNU/Hurd so try that.
-
-Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
-
----
- include/SFML/Config.hpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/include/SFML/Config.hpp b/include/SFML/Config.hpp
-index 84ec60f..7db03a9 100755
---- a/include/SFML/Config.hpp
-+++ b/include/SFML/Config.hpp
-@@ -49,7 +49,7 @@
- // MacOS
- #define SFML_SYSTEM_MACOS
-
--#elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
-+#elif defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__gnu_hurd__)
-
- // FreeBSD
- #define SFML_SYSTEM_FREEBSD
---
-tg: (1a017fb..) debian/kfreebsd (depends on: master)
diff --git a/debian/patches/debian/libpng-1.5.diff b/debian/patches/debian/libpng-1.5.diff
deleted file mode 100644
index 48ed743..0000000
--- a/debian/patches/debian/libpng-1.5.diff
+++ /dev/null
@@ -1,42 +0,0 @@
-From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
-Subject: [PATCH] debian/libpng-1.5
-
-Fix FTBFS libpng-1.5
-
-Signed-off-by: Dmitrijs Ledkovs <xnox@debian.org>
-
----
- src/SFML/Graphics/ImageLoader.cpp | 10 +++++++++-
- 1 file changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/src/SFML/Graphics/ImageLoader.cpp b/src/SFML/Graphics/ImageLoader.cpp
-index a3f83bf..a288482 100755
---- a/src/SFML/Graphics/ImageLoader.cpp
-+++ b/src/SFML/Graphics/ImageLoader.cpp
-@@ -44,7 +44,11 @@ namespace
- void PngErrorHandler(png_structp Png, png_const_charp Message)
- {
- std::cerr << "Failed to write PNG image. Reason : " << Message << std::endl;
-+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
-+ longjmp(png_jmpbuf((Png)),1);
-+#else
- longjmp(Png->jmpbuf, 1);
-+#endif
- }
- }
-
-@@ -289,7 +293,11 @@ bool ImageLoader::WritePng(const std::string& Filename, const std::vector<Color>
- }
-
- // For proper error handling...
-- if (setjmp(Png->jmpbuf))
-+#if PNG_LIBPNG_VER_MAJOR >= 1 && PNG_LIBPNG_VER_MINOR >= 4
-+ if (setjmp(png_jmpbuf(Png)))
-+#else
-+ if ( setjmp(Png->jmpbuf))
-+#endif
- {
- png_destroy_write_struct(&Png, &PngInfo);
- return false;
---
-tg: (afb79c7..) debian/libpng-1.5 (depends on: master)
diff --git a/debian/patches/debian/remove-Arial.hpp b/debian/patches/debian/remove-Arial.hpp
deleted file mode 100644
index 07d4111..0000000
--- a/debian/patches/debian/remove-Arial.hpp
+++ /dev/null
@@ -1,23 +0,0 @@
-Index: libsfml/src/SFML/Graphics/Font.cpp
-===================================================================
---- libsfml.orig/src/SFML/Graphics/Font.cpp 2012-07-08 21:07:00.520372052 +0200
-+++ libsfml/src/SFML/Graphics/Font.cpp 2012-07-08 21:07:00.670366273 +0200
-@@ -173,17 +173,11 @@
-
- #endif
-
-- // Get the raw data of the Arial font file into an array, so that we can load it into the font
-- static const char DefaultFontData[] =
-- {
-- #include <SFML/Graphics/Arial.hpp>
-- };
--
- // Load the default font on first call
- static bool DefaultFontLoaded = false;
- if (!DefaultFontLoaded)
- {
-- DefaultFont.LoadFromMemory(DefaultFontData, sizeof(DefaultFontData), 30);
-+ DefaultFont.LoadFromFile("/usr/share/fonts/truetype/freefont/FreeSans.ttf", 30);
- DefaultFontLoaded = true;
- }
-
diff --git a/debian/patches/debian/repacking.diff b/debian/patches/debian/repacking.diff
deleted file mode 100644
index 1fee7f5..0000000
--- a/debian/patches/debian/repacking.diff
+++ /dev/null
@@ -1,132 +0,0 @@
-From: Christoph Egger <Christoph.Egger@gmx.de>
-Subject: [PATCH] debian/repacking
-
- SFML Upstream Tarball ships loads of convenience copies in it's tarball and
-builds them inseparable in it's Makefiles.
-
- This patch removes the convenience-copies from all Makefiles and corrects the
-source-file to use the generic, system-wide libraries.
-
-Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
-
----
- src/SFML/Graphics/GraphicsContext.hpp | 2 +-
- src/SFML/Graphics/ImageLoader.cpp | 8 ++++----
- src/SFML/Graphics/Makefile | 19 +++----------------
- src/SFML/Window/Linux/WindowImplX11.cpp | 4 ++--
- src/SFML/Window/Makefile | 3 +--
- 5 files changed, 11 insertions(+), 25 deletions(-)
-
-diff --git a/src/SFML/Graphics/GraphicsContext.hpp b/src/SFML/Graphics/GraphicsContext.hpp
-index 2fa77a3..aebfe1f 100755
---- a/src/SFML/Graphics/GraphicsContext.hpp
-+++ b/src/SFML/Graphics/GraphicsContext.hpp
-@@ -30,7 +30,7 @@
- ////////////////////////////////////////////////////////////
- #include <SFML/Config.hpp>
- #include <SFML/System/NonCopyable.hpp>
--#include <SFML/Graphics/GLEW/glew.h>
-+#include <GL/glew.h>
- #include <iostream>
- #include <string>
-
-diff --git a/src/SFML/Graphics/ImageLoader.cpp b/src/SFML/Graphics/ImageLoader.cpp
-index a3f83bf..e6ceacd 100755
---- a/src/SFML/Graphics/ImageLoader.cpp
-+++ b/src/SFML/Graphics/ImageLoader.cpp
-@@ -28,11 +28,11 @@
- #include <SFML/Graphics/ImageLoader.hpp>
- extern "C"
- {
-- #include <SFML/Graphics/libjpeg/jpeglib.h>
-- #include <SFML/Graphics/libjpeg/jerror.h>
-+ #include <jpeglib.h>
-+ #include <jerror.h>
- }
--#include <SFML/Graphics/libpng/png.h>
--#include <SFML/Graphics/SOIL/SOIL.h>
-+#include <libpng/png.h>
-+#include <SOIL/SOIL.h>
- #include <iostream>
-
-
-diff --git a/src/SFML/Graphics/Makefile b/src/SFML/Graphics/Makefile
-index f149155..346f568 100755
---- a/src/SFML/Graphics/Makefile
-+++ b/src/SFML/Graphics/Makefile
-@@ -1,15 +1,5 @@
- SRC = $(wildcard *.cpp)
--SRCGLEW = $(wildcard ./GLEW/*.c)
--SRCJPEG = $(wildcard ./libjpeg/*.c)
--SRCPNG = $(wildcard ./libpng/*.c)
--SRCSOIL = $(wildcard ./SOIL/*.c)
--SRCZLIB = $(wildcard ./zlib/*.c)
- OBJ = $(SRC:.cpp=.o)
--OBJGLEW = $(SRCGLEW:.c=.o)
--OBJJPEG = $(SRCJPEG:.c=.o)
--OBJPNG = $(SRCPNG:.c=.o)
--OBJSOIL = $(SRCSOIL:.c=.o)
--OBJZLIB = $(SRCZLIB:.c=.o)
-
- ifeq ($(STATIC), yes)
- LIB = libsfml-graphics-s.a
-@@ -26,19 +16,16 @@ all: $(LIB)
- libsfml-graphics-s.a: $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
-
--libsfml-graphics.so: $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
-- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB) -lfreetype $(LIBPATH)/libsfml-system.so.$(VERSION) $(LIBPATH)/libsfml-window.so.$(VERSION) -lGL
-+libsfml-graphics.so: $(OBJ)
-+ $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) -lGLEW -ljpeg -lpng -lSOIL -lfreetype $(LIBPATH)/libsfml-system.so.$(VERSION) $(LIBPATH)/libsfml-window.so.$(VERSION) -lGL
-
- $(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS) -I/usr/include/freetype2
-
--$(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB): %.o: %.c
-- $(CC) -o $@ -c $< $(CFLAGSEXT) -DSTBI_FAILURE_USERMSG
--
- .PHONY: clean mrproper
-
- clean:
-- @rm -rf $(OBJ) $(OBJGLEW) $(OBJJPEG) $(OBJPNG) $(OBJSOIL) $(OBJZLIB)
-+ @rm -rf $(OBJ)
-
- mrproper: clean
- @rm -rf $(LIBNAME)
-diff --git a/src/SFML/Window/Linux/WindowImplX11.cpp b/src/SFML/Window/Linux/WindowImplX11.cpp
-index edec19b..f527864 100755
---- a/src/SFML/Window/Linux/WindowImplX11.cpp
-+++ b/src/SFML/Window/Linux/WindowImplX11.cpp
-@@ -27,8 +27,8 @@
- ////////////////////////////////////////////////////////////
- #include <SFML/Window/WindowStyle.hpp> // important to be included first (conflict with None)
- #include <SFML/Window/Linux/WindowImplX11.hpp>
--#include <SFML/Window/glext/glxext.h>
--#include <SFML/Window/glext/glext.h>
-+#include <GL/glxext.h>
-+#include <GL/glext.h>
- #include <SFML/System/Unicode.hpp>
- #include <X11/keysym.h>
- #include <X11/extensions/Xrandr.h>
-diff --git a/src/SFML/Window/Makefile b/src/SFML/Window/Makefile
-index a05a54b..5f9708e 100755
---- a/src/SFML/Window/Makefile
-+++ b/src/SFML/Window/Makefile
-@@ -1,6 +1,5 @@
- SRC = $(wildcard *.cpp ./Linux/*.cpp)
- OBJ = $(SRC:.cpp=.o)
--OBJGLEW = $(SRCGLEW:.c=.o)
-
- ifeq ($(STATIC), yes)
- LIB = libsfml-window-s.a
-@@ -18,7 +17,7 @@ libsfml-window-s.a: $(OBJ)
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ)
-
- libsfml-window.so: $(OBJ)
-- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) $(OBJGLEW) -lX11 -lXrandr -lGL $(LIBPATH)/libsfml-system.so.$(VERSION)
-+ $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) -lX11 -lXrandr -lGL $(LIBPATH)/libsfml-system.so.$(VERSION)
-
- $(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS)
---
-tg: (a419948..) debian/repacking (depends on: debian/interlinking)
diff --git a/debian/patches/debian/scriptheader-in-example-makefiles.diff b/debian/patches/debian/scriptheader-in-example-makefiles.diff
deleted file mode 100644
index b3969c7..0000000
--- a/debian/patches/debian/scriptheader-in-example-makefiles.diff
+++ /dev/null
@@ -1,157 +0,0 @@
-From: Christoph Egger <Christoph.Egger@gmx.de>
-Subject: [PATCH] debian/scriptheader-in-example-makefiles
-
- All sample Makefiles are executeable but do not have an script header. While
-making them non-executeable is an option, having them as working executeables
-seems more appropriate to me.
-
-Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
-
----
- samples/Makefile | 2 ++
- samples/X11/Makefile | 2 ++
- samples/ftp/Makefile | 2 ++
- samples/opengl/Makefile | 2 ++
- samples/pong/Makefile | 2 ++
- samples/post-fx/Makefile | 2 ++
- samples/qt/Makefile | 2 ++
- samples/sockets/Makefile | 2 ++
- samples/sound/Makefile | 2 ++
- samples/sound_capture/Makefile | 2 ++
- samples/voip/Makefile | 2 ++
- samples/window/Makefile | 2 ++
- samples/wxwidgets/Makefile | 2 ++
- 13 files changed, 26 insertions(+)
-
-diff --git a/samples/Makefile b/samples/Makefile
-index 938152a..7080454 100755
---- a/samples/Makefile
-+++ b/samples/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- export DEBUGBUILD = no
- ifeq ($(DEBUGBUILD), yes)
- DEBUGFLAGS = -g -DDEBUG
-diff --git a/samples/X11/Makefile b/samples/X11/Makefile
-index eca4cee..4bbc74e 100755
---- a/samples/X11/Makefile
-+++ b/samples/X11/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = X11
- OBJ = X11.o
-
-diff --git a/samples/ftp/Makefile b/samples/ftp/Makefile
-index 8bd25ae..26494b9 100755
---- a/samples/ftp/Makefile
-+++ b/samples/ftp/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = ftp
- OBJ = Ftp.o
-
-diff --git a/samples/opengl/Makefile b/samples/opengl/Makefile
-index 42ff5ca..96596af 100755
---- a/samples/opengl/Makefile
-+++ b/samples/opengl/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = opengl
- OBJ = OpenGL.o
-
-diff --git a/samples/pong/Makefile b/samples/pong/Makefile
-index 314ace2..dce1be8 100755
---- a/samples/pong/Makefile
-+++ b/samples/pong/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = pong
- OBJ = Pong.o
-
-diff --git a/samples/post-fx/Makefile b/samples/post-fx/Makefile
-index 2c25988..30f3dff 100755
---- a/samples/post-fx/Makefile
-+++ b/samples/post-fx/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = post-fx
- OBJ = PostFX.o
-
-diff --git a/samples/qt/Makefile b/samples/qt/Makefile
-index 43d09cd..3c48097 100755
---- a/samples/qt/Makefile
-+++ b/samples/qt/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = qt
- OBJ = Main.o QSFMLCanvas.o
-
-diff --git a/samples/sockets/Makefile b/samples/sockets/Makefile
-index 6adf020..771673e 100755
---- a/samples/sockets/Makefile
-+++ b/samples/sockets/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = sockets
- OBJ = Sockets.o TCP.o UDP.o
-
-diff --git a/samples/sound/Makefile b/samples/sound/Makefile
-index 495c13e..d42b4ba 100755
---- a/samples/sound/Makefile
-+++ b/samples/sound/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = sound
- OBJ = Sound.o
-
-diff --git a/samples/sound_capture/Makefile b/samples/sound_capture/Makefile
-index bc49217..0589c4a 100755
---- a/samples/sound_capture/Makefile
-+++ b/samples/sound_capture/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = sound_capture
- OBJ = SoundCapture.o
-
-diff --git a/samples/voip/Makefile b/samples/voip/Makefile
-index 1adca4e..a7b92d4 100755
---- a/samples/voip/Makefile
-+++ b/samples/voip/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = voip
- OBJ = VoIP.o Client.o Server.o
-
-diff --git a/samples/window/Makefile b/samples/window/Makefile
-index 6aa0abc..12f266b 100755
---- a/samples/window/Makefile
-+++ b/samples/window/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = window
- OBJ = Window.o
-
-diff --git a/samples/wxwidgets/Makefile b/samples/wxwidgets/Makefile
-index e6586ec..558e565 100755
---- a/samples/wxwidgets/Makefile
-+++ b/samples/wxwidgets/Makefile
-@@ -1,3 +1,5 @@
-+#!/usr/bin/make -f
-+
- EXEC = wxwidgets
- OBJ = Main.o wxSFMLCanvas.o
-
---
-tg: (6851b4d..) debian/scriptheader-in-example-makefiles (depends on: master)
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 8169a25..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,9 +0,0 @@
-debian/fix-includes.diff -p1
-debian/gcc-4.6.diff -p1
-debian/gcc-4.7.diff -p1
-debian/interlinking.diff -p1
-debian/kfreebsd.diff -p1
-debian/libpng-1.5.diff -p1
-debian/repacking.diff -p1
-debian/scriptheader-in-example-makefiles.diff -p1
-debian/remove-Arial.hpp