summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 49a8f04..bdf2475 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,9 @@ VER ?= $(subst $(DTYPE),,$(UVER))
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+# Only link libraries that are actually needed
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
%:
dh $@