summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 2 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index fd0ca2c..1c567f5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,22 +17,15 @@ get-orig-source:
wget http://downloads.sourceforge.net/sfml/SFML-1.5-sdk-linux-32.tar.gz ; \
tar -xzf SFML-1.5-sdk-linux-32.tar.gz ; cd SFML-1.5 ; \
find . \( -iname glew -o -iname glext -o -iname libjpeg \
- -o -iname libpng -o -iname zlib -o -iname SOIL \) -print | xargs /bin/rm -rf ; \
+ -o -iname libpng -o -iname zlib -o -iname SOIL \) -delete \
find samples \( -name "*.jpg" -o -name "*.png" -o -name "*.[ch]pp" -o \
-name "*.sfx" \) -print | xargs /bin/chmod a-x ;
make mrproper ; \
cd .. ; rm SFML-1.5-sdk-linux-32.tar.gz; mv SFML-1.5/* . ; rm -r SFML-1.5
cd .. ; dpkg-source -b -su libsfml libsfml-1.5.orig
-configure: configure-stamp
-configure-stamp: $(QUILT_STAMPFN)
- dh_testdir
-
- touch configure-stamp
-
-
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: $(QUILT_STAMPFN)
dh_testdir
-mkdir lib
$(MAKE) sfml