summaryrefslogtreecommitdiff
path: root/examples/joystick/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/joystick/CMakeLists.txt')
-rw-r--r--examples/joystick/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/joystick/CMakeLists.txt b/examples/joystick/CMakeLists.txt
new file mode 100644
index 0000000..f04dc7f
--- /dev/null
+++ b/examples/joystick/CMakeLists.txt
@@ -0,0 +1,11 @@
+
+set(SRCROOT ${PROJECT_SOURCE_DIR}/examples/joystick)
+
+# all source files
+set(SRC ${SRCROOT}/Joystick.cpp)
+
+# define the joystick target
+sfml_add_example(joystick GUI_APP
+ SOURCES ${SRC}
+ DEPENDS sfml-graphics sfml-window sfml-system
+ RESOURCES_DIR resources)