summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Changes4
-rw-r--r--MANIFEST2
-rw-r--r--MANIFEST.SKIP1
-rw-r--r--META.json6
-rw-r--r--META.yml4
-rw-r--r--Socket.pm2
-rw-r--r--Socket.xs13
-rw-r--r--debian/changelog7
-rw-r--r--debian/copyright2
-rw-r--r--t/getnameinfo.t4
10 files changed, 29 insertions, 16 deletions
diff --git a/Changes b/Changes
index d127047..9dbbe1a 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,9 @@
Revision history for Socket
+2.033 2022-04-29
+ [CHANGES]
+ * Apply patch from core perl for z/OS support (RT142470)
+
2.032 2021-06-03
[CHANGES]
* Attempt to support NetBSD's LOCAL_* constants (RT127989)
diff --git a/MANIFEST b/MANIFEST
index 965b426..1a35577 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -3,7 +3,7 @@ Changes
Copying
LICENSE
Makefile.PL
-MANIFEST
+MANIFEST This list of files
MANIFEST.SKIP
Socket.pm
Socket.xs
diff --git a/MANIFEST.SKIP b/MANIFEST.SKIP
index 8a23b00..5fe9f77 100644
--- a/MANIFEST.SKIP
+++ b/MANIFEST.SKIP
@@ -10,3 +10,4 @@ Socket-.*\.tar\.gz
.*\.bs
.*\.c
.*\.o
+.vimrc
diff --git a/META.json b/META.json
index 305737f..123f29f 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
"unknown"
],
"dynamic_config" : 1,
- "generated_by" : "ExtUtils::MakeMaker version 7.44, CPAN::Meta::Converter version 2.150010",
+ "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
"license" : [
"perl_5"
],
@@ -38,6 +38,6 @@
}
},
"release_status" : "stable",
- "version" : "2.032",
- "x_serialization_backend" : "JSON::PP version 4.05"
+ "version" : "2.033",
+ "x_serialization_backend" : "JSON::PP version 4.06"
}
diff --git a/META.yml b/META.yml
index 2dd1307..efeabd6 100644
--- a/META.yml
+++ b/META.yml
@@ -8,7 +8,7 @@ configure_requires:
ExtUtils::CBuilder: '0'
ExtUtils::Constant: '0.23'
dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.44, CPAN::Meta::Converter version 2.150010'
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -20,5 +20,5 @@ no_index:
- inc
requires:
perl: '5.006001'
-version: '2.032'
+version: '2.033'
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Socket.pm b/Socket.pm
index a1b7711..5087ffc 100644
--- a/Socket.pm
+++ b/Socket.pm
@@ -3,7 +3,7 @@ package Socket;
use strict;
{ use v5.6.1; }
-our $VERSION = '2.032';
+our $VERSION = '2.033';
=head1 NAME
diff --git a/Socket.xs b/Socket.xs
index b938562..fbf8054 100644
--- a/Socket.xs
+++ b/Socket.xs
@@ -224,10 +224,6 @@ static SV *my_newSVpvn_flags(pTHX_ const char *s, STRLEN len, U32 flags)
}
#endif /* !newSVpvn_flags */
-#ifndef SvRV_set
-# define SvRV_set(sv, val) (SvRV(sv) = (val))
-#endif /* !SvRV_set */
-
#ifndef SvPVbyte_nomg
# define SvPVbyte_nomg SvPV
#endif /* !SvPVbyte_nomg */
@@ -733,8 +729,13 @@ static void xs_getnameinfo(pTHX_ CV *cv)
#endif
err = getnameinfo((struct sockaddr *)sa, addr_len,
- want_host ? host : NULL, want_host ? sizeof(host) : 0,
- want_serv ? serv : NULL, want_serv ? sizeof(serv) : 0,
+#ifdef OS390 /* This OS requires both parameters to be non-NULL */
+ host, sizeof(host),
+ serv, sizeof(serv),
+#else
+ want_host ? host : NULL, want_host ? sizeof(host) : 0,
+ want_serv ? serv : NULL, want_serv ? sizeof(serv) : 0,
+#endif
flags);
Safefree(sa);
diff --git a/debian/changelog b/debian/changelog
index 8dc2bd9..f82f805 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+libsocket-perl (2.033-1) unstable; urgency=medium
+
+ * Import upstream version 2.033.
+ * Update years of packaging copyright.
+
+ -- gregor herrmann <gregoa@debian.org> Sat, 07 May 2022 17:55:39 +0200
+
libsocket-perl (2.032-1) unstable; urgency=medium
[ intrigeri ]
diff --git a/debian/copyright b/debian/copyright
index 4a5d42d..0b4a2f0 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -8,7 +8,7 @@ License: GPL-1+ or Artistic
Files: debian/*
Copyright: 2012, intrigeri <intrigeri@debian.org>
- 2012-2021, gregor herrmann <gregoa@debian.org>
+ 2012-2022, gregor herrmann <gregoa@debian.org>
License: GPL-1+ or Artistic
License: Artistic
diff --git a/t/getnameinfo.t b/t/getnameinfo.t
index 9441fb4..9bc0ab1 100644
--- a/t/getnameinfo.t
+++ b/t/getnameinfo.t
@@ -19,8 +19,8 @@ is( $host, undef, '$host is undef for NIx_NOHOST' );
is( $service, "80", '$service is 80 for NS, NIx_NOHOST' );
( $err, $host, $service ) = getnameinfo( pack_sockaddr_in( 80, inet_aton( "127.0.0.1" ) ), NI_NUMERICHOST|NI_NUMERICSERV, NIx_NOSERV );
-is( $host, "127.0.0.1", '$host is undef for NIx_NOSERV' );
-is( $service, undef, '$service is 80 for NS, NIx_NOSERV' );
+is( $host, "127.0.0.1", '$host is 127.0.0.1 for NIx_NOSERV' );
+is( $service, undef, '$service is undef for NS, NIx_NOSERV' );
( $err, $host, $service ) = getnameinfo( pack_sockaddr_in( 80, inet_aton( "127.0.0.1" ) ), NI_NUMERICSERV );
cmp_ok( $err, "==", 0, '$err == 0 for {family=AF_INET,port=80,sinaddr=127.0.0.1}/NI_NUMERICSERV' );