summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHamish Moffatt <hamish@debian.org>2002-01-06 13:02:15 +0100
committerHamish Moffatt <hamish@debian.org>2002-01-06 13:02:15 +0100
commit2679d213fe4eae9f00a496c9b5fa2a67c85e78e1 (patch)
tree8065f92eb2795042b55fa45c0ac74f539706e714 /Makefile.am
Import libstroke_0.5.1.orig.tar.gz
[dgit import orig libstroke_0.5.1.orig.tar.gz]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..48cd494
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,19 @@
+# don't build libgstroke if GTK is not available
+if HAVE_LIBGTK
+GSTROKE_SUBDS = libgstroke
+else
+GSTROKE_SUBDS =
+endif
+
+SUBDIRS = libstroke $(GSTROKE_SUBDS) tests doc javastroke
+
+EXTRA_DIST = COPYRIGHT CREDITS README.javastroke README.libgstroke
+
+m4datadir=$(datadir)/aclocal
+m4data_DATA=libstroke.m4 libgstroke.m4
+
+MOSTLYCLEANFILES = core *~
+CLEANFILES = core *~
+DISTCLEANFILES = core *~
+MAINTAINERCLEANFILES = core *~
+