summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..48cd494
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,19 @@
+# don't build libgstroke if GTK is not available
+if HAVE_LIBGTK
+GSTROKE_SUBDS = libgstroke
+else
+GSTROKE_SUBDS =
+endif
+
+SUBDIRS = libstroke $(GSTROKE_SUBDS) tests doc javastroke
+
+EXTRA_DIST = COPYRIGHT CREDITS README.javastroke README.libgstroke
+
+m4datadir=$(datadir)/aclocal
+m4data_DATA=libstroke.m4 libgstroke.m4
+
+MOSTLYCLEANFILES = core *~
+CLEANFILES = core *~
+DISTCLEANFILES = core *~
+MAINTAINERCLEANFILES = core *~
+