summaryrefslogtreecommitdiff
path: root/libgstroke/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgstroke/Makefile.am')
-rw-r--r--libgstroke/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/libgstroke/Makefile.am b/libgstroke/Makefile.am
new file mode 100644
index 0000000..8d6f5e3
--- /dev/null
+++ b/libgstroke/Makefile.am
@@ -0,0 +1,34 @@
+# A brief demonstration of using Automake with Libtool. -*-Makefile-*-
+#
+# NOTE: Don't forget that in the libtool distribution, files in this
+# directory are distributed by the demo_distfiles variable in the top
+# level Makefile.
+AUTOMAKE_OPTIONS = foreign
+
+EXTRA_DIST =
+
+#SEL_BIB = libgstroke.la
+
+lib_LTLIBRARIES = libgstroke.la
+libgstroke_la_SOURCES = gnome-stroke.c gnome-stroke-draw.c gstroke.h
+
+libgstroke_la_LDFLAGS = -version-info 0:5:0
+
+include_HEADERS = gstroke.h
+
+noinst_HEADERS = gstroke-internal.h
+
+INCLUDES = @GTK_CFLAGS@
+LDADD = @GTK_LIBS@
+
+EXTRA_DIST =
+
+MOSTLYCLEANFILES = core *~
+CLEANFILES = core *~
+DISTCLEANFILES = core *~
+MAINTAINERCLEANFILES = core *~
+
+# Unfortunately, in order to test libtool thoroughly, we need access
+# to its private directory.
+objdir = `sed -n -e 's/^objdir=\"\(.*\)\"$$/\1/p' ./libtool`
+