summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..0e402f5
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to produce Makefile.in
+
+if HAVE_LIBGTK
+GSTROKETEST = gnome_stroke_test
+else
+GSTROKETEST =
+endif
+
+
+noinst_PROGRAMS = stroke_test $(GSTROKETEST) #gstroke_conf
+
+# don't forget all *.h files */
+stroke_test_SOURCES = stroke_test.c #gstroke_conf.c
+gnome_stroke_test_SOURCES = gnome_stroke_test.c
+
+INCLUDES = -I$(top_srcdir)/libstroke -I$(top_srcdir)/libgstroke \
+ @X_CFLAGS@ @GTK_CFLAGS@
+
+stroke_test_LDADD = ../libstroke/libstroke.la @X_LDFLAGS@
+gnome_stroke_test_LDADD = ../libgstroke/libgstroke.la @GTK_LIBS@
+#gstroke_conf_LDADD = ../libstroke/libgstroke.la @X_LDFLAGS@
+
+EXTRA_DIST = stroke_test.tcl
+
+MOSTLYCLEANFILES = core *~
+CLEANFILES = core *~
+DISTCLEANFILES = core *~
+MAINTAINERCLEANFILES = core *~
+