summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2021-04-30 21:46:58 +0200
committergregor herrmann <gregoa@debian.org>2021-04-30 21:52:16 +0200
commitfc6d47491adf4f7943ecd2ca2a2e567c959a327f (patch)
tree876c50ebea8145d1548c856c7e77dac45cebef7b
parent85b034347cadc4c33022f2e191e22d54970ff228 (diff)
Don't run t/90close-leak.t during build and autopkgtests.
The test is flaky, and was probably meant as a release test for the upstream author in the first place. Thanks: Paul Gevers for the bug report. Closes: #987844
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/tests/pkg-perl/smoke-skip2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7810336..e4a9f25 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,9 +3,15 @@
PACKAGE = $(shell dh_listpackages)
TMP = $(CURDIR)/debian/$(PACKAGE)
+SKIP_TESTS = $(shell cat debian/tests/pkg-perl/smoke-skip)
+TEST_FILES = $(filter-out $(SKIP_TESTS), $(wildcard t/*.t))
+
%:
dh $@
+override_dh_auto_test:
+ dh_auto_test -- --test_files="$(TEST_FILES)"
+
override_dh_auto_install:
dh_auto_install
# boilerplate manpages
diff --git a/debian/tests/pkg-perl/smoke-skip b/debian/tests/pkg-perl/smoke-skip
new file mode 100644
index 0000000..e929607
--- /dev/null
+++ b/debian/tests/pkg-perl/smoke-skip
@@ -0,0 +1,2 @@
+# flaky, cf. #987844
+t/90close-leak.t