summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Bourg <ebourg@apache.org>2018-03-28 13:59:00 +0200
committerEmmanuel Bourg <ebourg@apache.org>2018-03-28 13:59:00 +0200
commitb66bd992c6a8e295c0fc1e86d90143cb69a25194 (patch)
tree52c3cc2eb57c136aecce8a6793e0a43f64179b39
parent45cc96427073ee6689c94c36cdb301ef2524a63b (diff)
Build with the DH sequencer instead of CDBS
-rw-r--r--debian/changelog1
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules15
3 files changed, 8 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index d23d4b9..dcf1222 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ libvldocking-java (2.1.4-5) UNRELEASED; urgency=low
* Team upload.
* Moved the package to Git (Closes: #670289)
+ * Build with the DH sequencer instead of CDBS
* Standards-Version updated to 4.1.3
* Switch to debhelper level 11
diff --git a/debian/control b/debian/control
index 9c893ac..c5de138 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,6 @@ Uploaders:
Varun Hiremath <varun@debian.org>
Build-Depends:
ant,
- cdbs,
debhelper (>= 11),
default-jdk
Standards-Version: 4.1.3
diff --git a/debian/rules b/debian/rules
index 0eef0fc..abcde9d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,12 @@
#!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/ant.mk
-
-JAVA_HOME := /usr/lib/jvm/default-java
-DEB_ANT_BUILD_TARGET := jar javadoc
JAR_VERSION := 2.1-beta
-install/libvldocking-java::
- dh_link /usr/share/java/vldocking_$(JAR_VERSION).jar \
- /usr/share/java/vldocking.jar
+%:
+ dh $@
+
+override_dh_auto_build:
+ dh_auto_build -- jar javadoc
+override_dh_auto_install:
+ dh_link /usr/share/java/vldocking_$(JAR_VERSION).jar /usr/share/java/vldocking.jar