summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2019-01-01 21:06:12 +0100
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2019-01-01 21:06:12 +0100
commitf1a6fd0b52239c90f76a1925af49003235bb95fd (patch)
tree60d7c662321745a909db230f51001a5755deaf8b
parent6fd7cb6f62eb108723b60dc0067e015fbbf7bf93 (diff)
Upstream now uses Maven
-rw-r--r--debian/control6
-rw-r--r--debian/libvldocking-java.jlibs1
-rw-r--r--debian/libvldocking-java.poms28
-rw-r--r--debian/maven.ignoreRules8
-rw-r--r--debian/maven.publishedRules1
-rw-r--r--debian/maven.rules3
-rw-r--r--debian/patches/build.diff26
-rw-r--r--debian/patches/java9-compatibility.diff73
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules6
10 files changed, 85 insertions, 68 deletions
diff --git a/debian/control b/debian/control
index 8dbab1e..4cea85c 100644
--- a/debian/control
+++ b/debian/control
@@ -6,10 +6,10 @@ Uploaders:
Torsten Werner <twerner@debian.org>,
Varun Hiremath <varun@debian.org>
Build-Depends:
- ant,
debhelper (>= 11),
default-jdk,
- javahelper
+ maven-debian-helper (>= 2.2),
+ maven-repo-helper (>= 1.5)
Standards-Version: 4.1.3
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-java/libvldocking-java.git
Vcs-Git: https://anonscm.debian.org/git/pkg-java/libvldocking-java.git
@@ -17,7 +17,7 @@ Homepage: http://code.google.com/p/vldocking/
Package: libvldocking-java
Architecture: all
-Depends: ${misc:Depends}
+Depends: ${misc:Depends}, ${maven:Depends}
Description: Java components for building applications with Docking capabilities
An application can be divided into sub-sets: the "dockables".
- Each Dockable can be precisely positioned by the user, by a drag and drop
diff --git a/debian/libvldocking-java.jlibs b/debian/libvldocking-java.jlibs
deleted file mode 100644
index e4ead8b..0000000
--- a/debian/libvldocking-java.jlibs
+++ /dev/null
@@ -1 +0,0 @@
-jar/vldocking.jar
diff --git a/debian/libvldocking-java.poms b/debian/libvldocking-java.poms
new file mode 100644
index 0000000..5ad70f2
--- /dev/null
+++ b/debian/libvldocking-java.poms
@@ -0,0 +1,28 @@
+# List of POM files for the package
+# Format of this file is:
+# <path to pom file> [option]*
+# where option can be:
+# --ignore: ignore this POM and its artifact if any
+# --ignore-pom: don't install the POM. To use on POM files that are created
+# temporarily for certain artifacts such as Javadoc jars. [mh_install, mh_installpoms]
+# --no-parent: remove the <parent> tag from the POM
+# --package=<package>: an alternative package to use when installing this POM
+# and its artifact
+# --has-package-version: to indicate that the original version of the POM is the same as the upstream part
+# of the version for the package.
+# --keep-elements=<elem1,elem2>: a list of XML elements to keep in the POM
+# during a clean operation with mh_cleanpom or mh_installpom
+# --artifact=<path>: path to the build artifact associated with this POM,
+# it will be installed when using the command mh_install. [mh_install]
+# --java-lib: install the jar into /usr/share/java to comply with Debian
+# packaging guidelines
+# --usj-name=<name>: name to use when installing the library in /usr/share/java
+# --usj-version=<version>: version to use when installing the library in /usr/share/java
+# --no-usj-versionless: don't install the versionless link in /usr/share/java
+# --dest-jar=<path>: the destination for the real jar.
+# It will be installed with mh_install. [mh_install]
+# --classifier=<classifier>: Optional, the classifier for the jar. Empty by default.
+# --site-xml=<location>: Optional, the location for site.xml if it needs to be installed.
+# Empty by default. [mh_install]
+#
+pom.xml --no-parent --has-package-version
diff --git a/debian/maven.ignoreRules b/debian/maven.ignoreRules
new file mode 100644
index 0000000..9cad088
--- /dev/null
+++ b/debian/maven.ignoreRules
@@ -0,0 +1,8 @@
+
+ch.qos.logback logback-classic * * * *
+junit junit * * * *
+org.apache.maven.plugins maven-deploy-plugin * * * *
+org.apache.maven.plugins maven-eclipse-plugin * * * *
+org.apache.maven.plugins maven-gpg-plugin * * * *
+org.apache.maven.plugins maven-javadoc-plugin * * * *
+org.apache.maven.plugins maven-source-plugin * * * *
diff --git a/debian/maven.publishedRules b/debian/maven.publishedRules
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/debian/maven.publishedRules
@@ -0,0 +1 @@
+
diff --git a/debian/maven.rules b/debian/maven.rules
new file mode 100644
index 0000000..1f73027
--- /dev/null
+++ b/debian/maven.rules
@@ -0,0 +1,3 @@
+
+s/dk.navicon/com.vldocking/ vldocking jar s/.*/debian/ * *
+org.apache.rat apache-rat-plugin * * * *
diff --git a/debian/patches/build.diff b/debian/patches/build.diff
deleted file mode 100644
index 71c0f3b..0000000
--- a/debian/patches/build.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: libvldocking-java-2.1.4/build.xml
-===================================================================
---- libvldocking-java-2.1.4.orig/build.xml 2008-01-23 23:10:03.000000000 +0530
-+++ libvldocking-java-2.1.4/build.xml 2008-01-23 23:10:17.000000000 +0530
-@@ -64,9 +64,9 @@
-
- <target name="jar" depends="compile">
-
-- <delete dir="${jar.dir}/vldocking_{$vldocking.version}.jar" />
-+ <delete dir="${jar.dir}/vldocking_${vldocking.version}.jar" />
-
-- <jar jarfile="${jar.dir}/vldocking_{$vldocking.version}.jar"
-+ <jar jarfile="${jar.dir}/vldocking_${vldocking.version}.jar"
- basedir="${build.dir}" >
- <include name="com/vlsolutions/**"/>
- <exclude name="**/doc-files/**"/>
-@@ -81,8 +81,7 @@
- use="true"
- source="1.4"
- overview="${src.dir}/com/vlsolutions/swing/docking/overview.html"
-- link="http://java.sun.com/j2se/1.5.0/docs/api"
-- windowtitle="VLSolutions Docking Framework {$vldocking.version} API">
-+ windowtitle="VLSolutions Docking Framework ${vldocking.version} API">
- <classpath>
- <pathelement path="${java.class.path}/"/>
- </classpath>
diff --git a/debian/patches/java9-compatibility.diff b/debian/patches/java9-compatibility.diff
index cddd6e0..0beaaa5 100644
--- a/debian/patches/java9-compatibility.diff
+++ b/debian/patches/java9-compatibility.diff
@@ -8,36 +8,45 @@ Forwarded: no
<javac destdir="${build.dir}"
classpath="${classpath};"
+ encoding="ISO-8859-1"
- debug="on" deprecation="off" optimize="on" source="1.4" target="1.4">
- <src path="${src.dir}"/>
- <include name="com/vlsolutions/**"/>
---- a/src/com/vlsolutions/swing/docking/DockingUtilities.java
-+++ b/src/com/vlsolutions/swing/docking/DockingUtilities.java
-@@ -82,7 +82,6 @@
- package com.vlsolutions.swing.docking;
+ debug="on" deprecation="off" optimize="on" includeantruntime="false">
+ <src path="${src.dir}"/>
+ <include name="com/vldocking/**"/>
+@@ -127,4 +128,4 @@
+ </target>
+ </project>
- import java.awt.*;
--import java.awt.peer.LightweightPeer;
- import java.lang.reflect.InvocationTargetException;
- import java.lang.reflect.Method;
- import java.util.ArrayList;
-@@ -350,8 +349,7 @@
- public static boolean isHeavyWeightComponent(Component comp){
- if (comp instanceof Container){
- // short cut
-- Object peer = comp.getPeer();
-- if (!(peer == null || peer instanceof LightweightPeer)){
-+ if (comp.isDisplayable() && !comp.isLightweight()){
- // it's not a lightweight
- return true;
- } else {
-@@ -366,8 +364,7 @@
- return false;
- }
- } else {
-- Object peer = comp.getPeer();
-- return !(peer == null || peer instanceof LightweightPeer);
-+ return comp.isDisplayable() && !comp.isLightweight();
- }
- }
-
+-<!-- End of build.xml -->
+\ No newline at end of file
++<!-- End of build.xml -->
+--- a/src/main/java/com/vlsolutions/swing/docking/DockingUtilities.java
++++ b/src/main/java/com/vlsolutions/swing/docking/DockingUtilities.java
+@@ -19,7 +19,6 @@
+ package com.vlsolutions.swing.docking;
+
+ import java.awt.*;
+-import java.awt.peer.LightweightPeer;
+ import java.lang.reflect.InvocationTargetException;
+ import java.lang.reflect.Method;
+ import java.util.ArrayList;
+@@ -291,9 +290,7 @@
+ public static boolean isHeavyWeightComponent(Component comp) {
+ if(comp instanceof Container) {
+ // short cut
+- @SuppressWarnings("deprecation")
+- Object peer = comp.getPeer();
+- if(! (peer == null || peer instanceof LightweightPeer)) {
++ if (comp.isDisplayable() && !comp.isLightweight()){
+ // it's not a lightweight
+ return true;
+ } else {
+@@ -308,9 +305,7 @@
+ return false;
+ }
+ } else {
+- @SuppressWarnings("deprecation")
+- Object peer = comp.getPeer();
+- return ! (peer == null || peer instanceof LightweightPeer);
++ return comp.isDisplayable() && !comp.isLightweight();
+ }
+ }
+
diff --git a/debian/patches/series b/debian/patches/series
index 8effed7..87014c1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
-build.diff
java9-compatibility.diff
diff --git a/debian/rules b/debian/rules
index 8307182..ec38b7c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,4 @@
#!/usr/bin/make -f
%:
- dh $@ --with javahelper
-
-override_dh_auto_build:
- dh_auto_build
- mv jar/vldocking_2.1-beta.jar jar/vldocking.jar
+ dh $@ --buildsystem=maven