summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Pion <pion@afnic.fr>2022-08-24 17:02:19 +0200
committerAlexandre Pion <pion@afnic.fr>2022-08-24 17:02:19 +0200
commitd3f7e396b399badc55199b37a6cbab397239e656 (patch)
treea9bfe439e29014fca3e3f6ba72478176dc200894
parentfb6c9ff85a51bb026dc3073695df6eddc2a0bfde (diff)
Debug option
-rw-r--r--Makefile.PL9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index cf5c342..223d0d8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -58,6 +58,10 @@ The PATH is passed to the LDNS compiler via the CFLAGS variable.
Search for OpenSSL library in PATH.
The PATH is passed to the LDNS compiler via the LDFLAGS variable.
+=item --debug
+
+Enable debug mode, more verbose output.
+
=back
=cut
@@ -69,6 +73,7 @@ my $opt_randomize = 0;
my $opt_prefix_openssl = "";
my $opt_openssl_inc = "";
my $opt_openssl_lib = "";
+my $opt_debug = 0;
GetOptions(
'ed25519!' => \$opt_ed25519,
'idn!' => \$opt_idn,
@@ -77,6 +82,7 @@ GetOptions(
'prefix-openssl=s' => \$opt_prefix_openssl,
'openssl-inc=s' => \$opt_openssl_inc,
'openssl-lib=s' => \$opt_openssl_lib,
+ 'debug!' => \$opt_debug,
);
configure_requires 'Devel::CheckLib';
@@ -125,6 +131,7 @@ else {
}
cc_assert_lib(
+ debug => $opt_debug,
lib => 'crypto',
header => 'openssl/crypto.h',
function => 'if(SSLeay()) return 0; else return 1;',
@@ -133,6 +140,7 @@ cc_assert_lib(
if ( $opt_ed25519 ) {
print "Feature Ed25519 enabled\n";
cc_assert_lib(
+ debug => $opt_debug,
lib => 'crypto',
header => 'openssl/evp.h',
function => 'EVP_PKEY_ED25519; return 0;',
@@ -156,6 +164,7 @@ else {
cc_libs 'ldns';
if ( $opt_ed25519 ) {
cc_assert_lib(
+ debug => $opt_debug,
lib => 'ldns',
header => 'ldns/ldns.h',
ccflags => '-DUSE_ED25519',