summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Pion <pion@afnic.fr>2022-10-20 16:37:35 +0200
committerAlexandre Pion <pion@afnic.fr>2022-10-20 17:07:46 +0200
commit8fc702f74608fccb715763bca5512a5587438e70 (patch)
tree5b098ff0841e592a752dedf80269fc9bd4884026
parent1411fcb2509788ce70e9fd25670e0550572e9f51 (diff)
Fix libldns reconfiguration on update
Use prerequisites to check for submodule existence and rebuild it on change (based on Changelog file updates).
-rw-r--r--Makefile.PL8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 9f4fc66..c4a557c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -352,12 +352,14 @@ ldns/.libs/libldns.a: ldns/configure
./configure CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(CONFIGURE_FLAGS) ;\
make lib
-ldns/configure:
+ldns/configure: ldns/Changelog
+ cd ldns ; libtoolize -ci
+ cd ldns ; autoreconf -fi
+
+ldns/Changelog:
git submodule init
git submodule sync
git submodule update
- cd ldns ; libtoolize -ci
- cd ldns ; autoreconf -fi
END_INTERNAL_LDNS