summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2017-03-06 18:50:55 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2017-03-08 21:33:47 +0000
commitd09bc77b5d44cb91a780dc7fd6d1a125a5c8fc56 (patch)
tree47602ec348954940f8abb98748976ad4ce407f80
parent1d8db2007b420c0e9601be49567e1a1dd6ac33be (diff)
-rw-r--r--.gitignore14
-rw-r--r--Makefile.in3
-rw-r--r--configure.ac9
-rw-r--r--debian/.gitignore7
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control31
-rw-r--r--debian/copyright17
-rw-r--r--debian/docs2
-rw-r--r--debian/litmus.134
-rw-r--r--debian/manpages1
-rw-r--r--debian/patches/01_no_bundled_neon54
-rw-r--r--debian/patches/gitignore17
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules12
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options1
-rw-r--r--debian/watch2
18 files changed, 203 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..52e2e15
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.o
+Makefile
+basic
+*.log
+config.h
+config.log
+config.status
+copymove
+http
+*.a
+litmus
+locks
+props
+autom4te.cache
diff --git a/Makefile.in b/Makefile.in
index 5a183a4..307ce0e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -94,18 +94,15 @@ largefile: src/largefile.o $(ODEPS)
$(CC) $(LDFLAGS) -o $@ src/largefile.o $(ALL_LIBS)
subdirs:
- @cd lib/neon && $(MAKE)
libtest.a: $(TESTOBJS)
$(AR) cru $@ $(TESTOBJS)
$(RANLIB) $@
clean:
- @cd lib/neon && $(MAKE) clean
rm -f */*.o $(TESTS) largefile libtest.a *~ debug.log child.log
distclean: clean
- @cd lib/neon && $(MAKE) distclean
rm Makefile litmus config.log config.h config.status
.c.o:
diff --git a/configure.ac b/configure.ac
index e6b7800..bbb3fae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@ AC_PROG_INSTALL
dnl List of tests
AC_SUBST([TESTS], ["basic copymove props locks http"])
-NE_REQUIRE_VERSIONS([0], [25 26 27 28 29])
+NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30])
NEON_WITHOUT_ZLIB
NEON_WITHOUT_ACL
NEON_TEST
@@ -39,7 +39,7 @@ NEON_WARNINGS
CPPFLAGS="$CPPFLAGS -I\${top_builddir} -I\$(top_srcdir)/lib"
AC_CONFIG_FILES([litmus], [chmod +x litmus])
-AC_CONFIG_FILES([Makefile lib/neon/Makefile])
+AC_CONFIG_FILES([Makefile])
AC_OUTPUT
@@ -51,8 +51,3 @@ AC_MSG_NOTICE([Configured to build AC_PACKAGE_STRING:
XML parser: ${neon_xml_parser_message}
SSL library: ${ne_SSL_message}
])
-
-# For VPATH builds
-for d in lib lib/expat lib/neon test-common src; do
- test -d $d || mkdir $d
-done
diff --git a/debian/.gitignore b/debian/.gitignore
new file mode 100644
index 0000000..bbf1946
--- /dev/null
+++ b/debian/.gitignore
@@ -0,0 +1,7 @@
+.debhelper/
+debhelper-build-stamp
+*.substvars
+*.debhelper.log
+litmus/
+files
+autoreconf.*
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..fafbb2d
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+litmus (0.13-1) unstable; urgency=low
+
+ * Initial release. Closes: #856982
+
+ -- Jelmer Vernooij <jelmer@debian.org> Mon, 06 Mar 2017 18:39:27 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..4517f55
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,31 @@
+Source: litmus
+Section: web
+Priority: optional
+Maintainer: Jelmer Vernooij <jelmer@debian.org>
+Homepage: http://www.webdav.org/neon/litmus/
+Build-Depends: debhelper (>= 9.20160114), libneon27-gnutls-dev, dh-autoreconf
+Standards-Version: 3.9.8
+Vcs-Git: https://anonscm.debian.org/git/users/jelmer/litmus.git
+Vcs-Browser: https://anonscm.debian.org/cgit/users/jelmer/litmus.git
+
+Package: litmus
+Architecture: any
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: WebDAV server test suite
+ A WebDAV server protocol compliance test suite. Tests include:
+ .
+ * OPTIONS for DAV: header
+ * PUT, GET with byte comparison
+ * MKCOL
+ * DELETE (collections, non-collections)
+ * COPY, MOVE using combinations of:
+ - overwrite t/f
+ - destination exists/doesn't exist
+ - collection/non-collection
+ * Property manipulation and querying:
+ - set, delete, replace properties
+ - persist dead props across COPY
+ - namespace handling
+ * Locking
+ - attempts to modify locked resource (as lock owner, not owner)
+ - shared/exclusive locks, lock discovery
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..5fa521c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,17 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: litmus
+Upstream-Contact: litmus@lists.manyfish.co.uk
+Source: https://www.dulwich.io/
+Debianized-By: Jelmer Vernooij <jelmer@debian.org>
+Debianized-Date: 6 Mar 2017
+Files-Excluded: lib/neon/* lib/expat/*
+
+License: GPL-2+
+ On Debian systems the full text of the GNU General Public License version 2
+ can be found in the `/usr/share/common-licenses/GPL-2' file.
+
+Files: *
+Copyright:
+ 1998-2011 Joe Orton <joe@manyfish.co.uk>
+ 2004 Aleix Conchillo Flaque <aleix@member.fsf.org>
+License: GPL-2+
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..5b97370
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+README
+FAQ
diff --git a/debian/litmus.1 b/debian/litmus.1
new file mode 100644
index 0000000..18c173a
--- /dev/null
+++ b/debian/litmus.1
@@ -0,0 +1,34 @@
+.TH LITMUS "1" "March 2017" "litmus 0.13" "User Commands"
+.SH NAME
+litmus \- WebDAV server test suite
+.SH DESCRIPTION
+Litmus is a WebDAV server test suite.
+.SH SYNOPSIS
+\fI\,/usr/bin/litmus\/\fP [OPTIONS] URL [USERNAME PASSWORD]
+.SH OPTIONS
+.TP
+\fB\-k\fR, \fB\-\-keep\-going\fR
+continue testing even if one suite fails
+.TP
+\fB\-p\fR, \fB\-\-proxy\fR=\fI\,URL\/\fR
+use given proxy server URL
+.TP
+\fB\-c\fR, \fB\-\-client\-cert\fR=\fI\,CERT\/\fR
+use given PKCS#12 client cert
+.SH ENVIRONMENT
+Significant environment variables:
+.TP
+$TESTS
+\- specify test programs to run
+.IP
+default: "basic copymove props locks http"
+.TP
+$HTDOCS
+\- specify alternate document root
+.IP
+default: \fI\,/usr/share/litmus/htdocs\/\fP
+.TP
+$TESTROOT
+\- specify alternate program directory
+.IP
+default: \fI\,/usr/lib/x86_64\-linux\-gnu/litmus\/\fP
diff --git a/debian/manpages b/debian/manpages
new file mode 100644
index 0000000..db07e8f
--- /dev/null
+++ b/debian/manpages
@@ -0,0 +1 @@
+debian/litmus.1
diff --git a/debian/patches/01_no_bundled_neon b/debian/patches/01_no_bundled_neon
new file mode 100644
index 0000000..7e0c9e1
--- /dev/null
+++ b/debian/patches/01_no_bundled_neon
@@ -0,0 +1,54 @@
+diff --git a/Makefile.in b/Makefile.in
+index 5a183a4..307ce0e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -94,18 +94,15 @@ largefile: src/largefile.o $(ODEPS)
+ $(CC) $(LDFLAGS) -o $@ src/largefile.o $(ALL_LIBS)
+
+ subdirs:
+- @cd lib/neon && $(MAKE)
+
+ libtest.a: $(TESTOBJS)
+ $(AR) cru $@ $(TESTOBJS)
+ $(RANLIB) $@
+
+ clean:
+- @cd lib/neon && $(MAKE) clean
+ rm -f */*.o $(TESTS) largefile libtest.a *~ debug.log child.log
+
+ distclean: clean
+- @cd lib/neon && $(MAKE) distclean
+ rm Makefile litmus config.log config.h config.status
+
+ .c.o:
+diff --git a/configure.ac b/configure.ac
+index e6b7800..bbb3fae 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,7 +20,7 @@ AC_PROG_INSTALL
+ dnl List of tests
+ AC_SUBST([TESTS], ["basic copymove props locks http"])
+
+-NE_REQUIRE_VERSIONS([0], [25 26 27 28 29])
++NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30])
+ NEON_WITHOUT_ZLIB
+ NEON_WITHOUT_ACL
+ NEON_TEST
+@@ -39,7 +39,7 @@ NEON_WARNINGS
+ CPPFLAGS="$CPPFLAGS -I\${top_builddir} -I\$(top_srcdir)/lib"
+
+ AC_CONFIG_FILES([litmus], [chmod +x litmus])
+-AC_CONFIG_FILES([Makefile lib/neon/Makefile])
++AC_CONFIG_FILES([Makefile])
+
+ AC_OUTPUT
+
+@@ -51,8 +51,3 @@ AC_MSG_NOTICE([Configured to build AC_PACKAGE_STRING:
+ XML parser: ${neon_xml_parser_message}
+ SSL library: ${ne_SSL_message}
+ ])
+-
+-# For VPATH builds
+-for d in lib lib/expat lib/neon test-common src; do
+- test -d $d || mkdir $d
+-done
diff --git a/debian/patches/gitignore b/debian/patches/gitignore
new file mode 100644
index 0000000..b1a76a7
--- /dev/null
+++ b/debian/patches/gitignore
@@ -0,0 +1,17 @@
+--- /dev/null
++++ litmus-0.13/.gitignore
+@@ -0,0 +1,14 @@
++*.o
++Makefile
++basic
++*.log
++config.h
++config.log
++config.status
++copymove
++http
++*.a
++litmus
++locks
++props
++autom4te.cache
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..d16226e
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+01_no_bundled_neon
+gitignore
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0152242
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_auto_test:
+ echo Not runnig tests, as they require a server.
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..3ec613a
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1 @@
+extend-diff-ignore = "^(\.travis.yml|\.gitignore)$"
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..c4e5d18
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://www.webdav.org/neon/litmus/ litmus-(.*).tar.gz