summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Bremner <david@tethera.net>2019-01-13 09:36:32 -0400
committerDavid Bremner <david@tethera.net>2019-01-13 11:06:38 -0400
commit65e4ccab579cdf3e46f104f29bef35dcb856eb31 (patch)
treec51955d938372ac96b3f78a300b576ea29ff8e5c
parentdff50be4521ee69cfb070596e4a98ff33eaee290 (diff)
disable 128bit arithmetic on debian builds of 32bit architectures
-rwxr-xr-xdebian/rules10
1 files changed, 8 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ba7556e..cdd8be5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,11 +9,17 @@ CPPFLAGS=$(shell dpkg-buildflags --get CPPFLAGS)
LDFLAGS=$(shell dpkg-buildflags --get LDFLAGS)
export CFLAGS CPPFLAGS LDFLAGS
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH_BITS),32)
+BUILDARGS=SHLIBOBJ2="" BITS=-DB32
+else
+BUILDARGS=
+endif
+
override_dh_auto_build: lrslib.1 nash.1
- make prefix=/usr DESTDIR=$(CURDIR)/debian/tmp all-shared
+ make prefix=/usr DESTDIR=$(CURDIR)/debian/tmp $(BUILDARGS) all-shared
override_dh_auto_install:
- make prefix=/usr DESTDIR=$(CURDIR)/debian/tmp install
+ make prefix=/usr DESTDIR=$(CURDIR)/debian/tmp $(BUILDARGS) install
%:
dh $@