summaryrefslogtreecommitdiff
path: root/lsb_release.py
diff options
context:
space:
mode:
authorMarcel Partap <mpartap@gmx.net>2014-05-28 18:36:04 +0200
committerDidier Raboud <odyx@debian.org>2014-05-28 18:36:04 +0200
commit59fb4f343e8ade8b280d0450cf5940423e564d19 (patch)
treee5d03cb92b134f926670b86556ad3dc9aae0506e /lsb_release.py
parent9c6f5395ed006dcf8f5ad0c9e81396d7dccf0b33 (diff)
In lsb_release, don't forget CODENAME when it's testing; therefore stop calling apt-cache policy again
Closes: #747413
Diffstat (limited to 'lsb_release.py')
-rw-r--r--lsb_release.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/lsb_release.py b/lsb_release.py
index ecf46e3..6b9e226 100644
--- a/lsb_release.py
+++ b/lsb_release.py
@@ -304,6 +304,7 @@ def guess_debian_release():
if release.rstrip('/sid').lower().isalpha() != 'testing':
global TESTING_CODENAME
TESTING_CODENAME = release.rstrip('/sid')
+ distinfo['CODENAME'] = TESTING_CODENAME
distinfo['RELEASE'] = 'testing/unstable'
else:
distinfo['RELEASE'] = release