summaryrefslogtreecommitdiff
path: root/lsb_release.py
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2015-08-12 14:09:52 +0200
committerDidier Raboud <odyx@debian.org>2015-08-12 14:18:25 +0200
commit7d273183b96ba9a9b4bd572a4d088c3d921f4710 (patch)
treef21bd3e34c7aa572f33894335715baa6e16c6bfc /lsb_release.py
parenta13cd11eb235c4ff56a93fdd740cc1d516555ea0 (diff)
Make sure '-proposed-updates' don't sort before unstable
Diffstat (limited to 'lsb_release.py')
-rw-r--r--lsb_release.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/lsb_release.py b/lsb_release.py
index 9bdd366..e11aead 100644
--- a/lsb_release.py
+++ b/lsb_release.py
@@ -43,7 +43,7 @@ def get_distro_info(origin='Debian'):
if origin.lower() == 'debian':
TESTING_CODENAME = 'unknown.new.testing'
- RELEASES_ORDER.extend(['stable', 'testing', 'unstable', 'sid'])
+ RELEASES_ORDER.extend(['stable', 'proposed-updates', 'testing', 'testing-proposed-updates', 'unstable', 'sid'])
csvfile.close()
@@ -235,6 +235,7 @@ def guess_release_from_apt(origin='Debian', component='main',
# We only care about the specified origin, component, and label
releases = [x for x in releases if (
x[1].get('origin', '') == origin and
+ x[1].get('suite', '') not in ignoresuites and
x[1].get('component', '') == component and
x[1].get('label', '') == label) or (
x[1].get('origin', '') in alternate_olabels and
@@ -306,7 +307,7 @@ def guess_debian_release():
codename = lookup_codename(release, 'n/a')
distinfo.update({ 'RELEASE' : release, 'CODENAME' : codename })
elif release.endswith('/sid'):
- if release.rstrip('/sid').lower().isalpha() != 'testing':
+ if release.rstrip('/sid').lower() != 'testing':
global TESTING_CODENAME
TESTING_CODENAME = release.rstrip('/sid')
distinfo['RELEASE'] = 'testing/unstable'