summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-07-07 12:58:05 +0100
committerColin Watson <cjwatson@debian.org>2019-07-07 12:58:05 +0100
commit16b86240c9fd4cc9aed088e019e9fad24e8c9c5e (patch)
tree573bee1e39ffb58d157548c9eb3b8d66d04fed55
parentd03e636cb62cfb676262d872a99408bfbca3f25c (diff)
make-local-mirror: Update testing-security spelling
testing-security is spelled thus on mirrors as of bullseye, not testing/updates. Closes: #931518
-rw-r--r--debian/changelog2
-rw-r--r--examples/local-mirror.config2
-rwxr-xr-xexamples/make-local-mirror19
3 files changed, 11 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 094198c..0b301c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ madison-lite (0.25) UNRELEASED; urgency=medium
- Stop using ftp:// URLs.
- Fetch .bz2 or .xz as appropriate, not .gz.
- Fix security source mirroring.
+ - testing-security is spelled thus on mirrors as of bullseye, not
+ testing/updates (closes: #931518).
-- Colin Watson <cjwatson@debian.org> Sun, 07 Jul 2019 12:28:03 +0100
diff --git a/examples/local-mirror.config b/examples/local-mirror.config
index 11b0479..6d29fc8 100644
--- a/examples/local-mirror.config
+++ b/examples/local-mirror.config
@@ -9,7 +9,7 @@ suite testing-proposed-updates dists/testing-proposed-updates main contrib non-f
suite unstable dists/unstable main contrib non-free
suite experimental dists/experimental main contrib non-free
suite stable/updates dists/stable-security main contrib non-free
-suite testing/updates dists/testing-security main contrib non-free
+suite testing-security dists/testing-security main contrib non-free
# Uncomment the following lines if you are mirroring Ubuntu index files as
# well.
# suite precise dists/precise main restricted universe multiverse
diff --git a/examples/make-local-mirror b/examples/make-local-mirror
index 9c1a478..86dc07f 100755
--- a/examples/make-local-mirror
+++ b/examples/make-local-mirror
@@ -36,25 +36,21 @@ for archive in $archives; do
case $archive in
main)
host="$HOST_MAIN"
- suitesuffix=''
suites='stable proposed-updates testing testing-proposed-updates unstable experimental'
components='main contrib non-free'
;;
security)
host="$HOST_SECURITY"
- suitesuffix='/updates'
- suites='stable testing'
+ suites='stable/updates:stable-security testing-security'
components='main contrib non-free'
;;
ubuntu)
host="$HOST_UBUNTU"
- suitesuffix=''
suites='precise trusty xenial bionic cosmic disco eoan'
components='main restricted universe multiverse'
;;
ubuntu-ports)
host="$HOST_UBUNTU_PORTS"
- suitesuffix=''
suites='precise trusty xenial bionic cosmic disco eoan'
components='main restricted universe multiverse'
;;
@@ -64,12 +60,13 @@ for archive in $archives; do
esac
for suite in $suites; do
- case $archive in
- main|ubuntu*)
- suitehere="$suite"
+ case $suite in
+ *:*)
+ suitehere="${suite#*:}"
+ suite="${suite%%:*}"
;;
*)
- suitehere="$suite-$archive"
+ suitehere="$suite"
;;
esac
@@ -107,10 +104,10 @@ for archive in $archives; do
mkdir -p "$suitehere/$component"
for arch in $arches; do
mkdir -p "$suitehere/$component/binary-$arch"
- wget $WGET_OPTS -O "$suitehere/$component/binary-$arch/Packages$ext" "$host/$root/$suite$suitesuffix/$component/binary-$arch/Packages$ext"
+ wget $WGET_OPTS -O "$suitehere/$component/binary-$arch/Packages$ext" "$host/$root/$suite/$component/binary-$arch/Packages$ext"
done
mkdir -p "$suitehere/$component/source"
- wget $WGET_OPTS -O "$suitehere/$component/source/Sources$ext" "$host/$root/$suite$suitesuffix/$component/source/Sources$ext"
+ wget $WGET_OPTS -O "$suitehere/$component/source/Sources$ext" "$host/$root/$suite/$component/source/Sources$ext"
done
done
done