summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-15 01:45:51 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-15 01:45:51 -0800
commit3da3dd1274e5ec53fa3a44484c0dc017963fdee1 (patch)
tree05aecaee5ff66b4d9536dd2420983722e145f138
parent7d25dd10e1929e6e74c007088f4541aa8dfa067f (diff)
[master]: Fix wrong declaration of a function
Made the header file match the actual implementation. Bug fix: "Conflicting return type declarations of function init_env", thanks to Michael Tautschnig (Closes: #749680). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--agent/filter/environ.h4
-rw-r--r--debian/changelog8
2 files changed, 10 insertions, 2 deletions
diff --git a/agent/filter/environ.h b/agent/filter/environ.h
index f98efb3..3e76aa1 100644
--- a/agent/filter/environ.h
+++ b/agent/filter/environ.h
@@ -14,7 +14,7 @@
* $Id: environ.h 1 2006-08-24 13:24:12Z rmanfredi $
*
* Copyright (c) 1990-2006, Raphael Manfredi
- *
+ *
* You may redistribute only under the terms of the Artistic License,
* as specified in the README file that comes with the distribution.
* You may reuse parts of this distribution only within the terms of
@@ -34,7 +34,7 @@
#define _environ_h_
extern void print_env(); /* Print the environment */
-extern void init_env(); /* Initializes the environment table */
+extern int init_env(char **envp); /* Initializes the environment table */
extern char **make_env(); /* Make a new system environment */
extern int append_env(); /* Append value to environment */
extern int prepend_env(); /* Prepend value to environment */
diff --git a/debian/changelog b/debian/changelog
index a4e29d7..e8bc2ac 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mailagent (1:3.1-81-1) unstable; urgency=low
+
+ * New upstream release
+ * Bug fix: "Conflicting return type declarations of function init_env",
+ thanks to Michael Tautschnig (Closes: #749680).
+
+ -- Manoj Srivastava <srivasta@debian.org> Fri, 15 Jan 2016 01:44:18 -0800
+
mailagent (1:3.1-78-1) unstable; urgency=low
* New upstream release