summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-21 23:33:29 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-21 23:41:58 -0800
commit5445b3d887757644d236fb4f3fcfd356dbbe8353 (patch)
treef2b6b7a10748d3c57eb9ec55230adb77fe2474d9
parent6370f93b28a6f7fab02523553abc9c61b12dbe5b (diff)
[master]: Messages should be dropped in the system mailbodebian/1%3.1-81-3
When the LEAVE command is used, messages should be dropped into the system mailbox of the user (/var/spool/mail/$user, which is the value of the $mailfile variable, defined in /usr/bin/mailagent ). Instead of that, the messages are dropped into ~/mbox.$user. The patch attached to this bug report fixes the problem. The bug comes clearly from a typo and it is surprising that it has not yet been noticed. Bug fix: "Messages should be dropped in the system mailbox when using the LEAVE command", thanks to Rafael Laboissiere (Closes: #812308). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rwxr-xr-xagent/magent.sh10
-rw-r--r--debian/changelog8
-rw-r--r--debian/control6
3 files changed, 17 insertions, 7 deletions
diff --git a/agent/magent.sh b/agent/magent.sh
index c921a7c..dc691aa 100755
--- a/agent/magent.sh
+++ b/agent/magent.sh
@@ -28,7 +28,7 @@ $startperl
# $Id: magent.sh,v 3.0.1.17 2001/03/17 18:07:49 ram Exp ram $
#
# Copyright (c) 1990-2006, Raphael Manfredi
-#
+#
# You may redistribute only under the terms of the Artistic License,
# as specified in the README file that comes with the distribution.
# You may reuse parts of this distribution only within the terms of
@@ -380,10 +380,10 @@ if (!$run_queue) { # Do not enter here if -q
&queue_mail($file_name, 'fm');
unlink $lockfile;
exit 0; # Do not continue
- }
+ }
# If invoked from a tty and not in test mode, do not process queue
- $process_queue = 0 if -t STDOUT && !$test_mode;
+ $process_queue = 0 if -t STDOUT && !$test_mode;
}
if ($process_queue) {
@@ -505,7 +505,7 @@ sub init_constants {
$NO_FEEDBACK = 0; # No feedback wanted
$FEEDBACK = 1; # Feed result of command back into %Header
$FEEDBACK_ENCODING = 2; # Same as $FEEDBACK, but probe body for encoding
-
+
# The filter message
local($address) = &email_addr;
$FILTER =
@@ -717,7 +717,7 @@ sub mailbox_name {
$mailbox =~ s/%~/$cf'home/go; # %~ stands for the user directory
$mailbox =~ s/%L/$cf'user/go; # %L stands for the user login name
$mailbox =~ m|(.*)/.*|; # Extract dirname
- $mailbox = "$cf'home/mbox.$cf'user" unless (-f "mailbox" || -w "$1");
+ $mailbox = "$cf'home/mbox.$cf'user" unless (-f "$mailbox" || -w "$1");
&add_log("WARNING using $mailbox for mailbox") if $loglvl > 5;
}
$mailbox;
diff --git a/debian/changelog b/debian/changelog
index f4231dc..fa35eee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+mailagent (1:3.1-81-3) unstable; urgency=low
+
+ * New bug fixing release
+ * Bug fix: "Messages should be dropped in the system mailbox when using
+ the LEAVE command", thanks to Rafael Laboissiere (Closes: #812308).
+
+ -- Manoj Srivastava <srivasta@debian.org> Thu, 21 Jan 2016 23:32:46 -0800
+
mailagent (1:3.1-81-2) unstable; urgency=low
* New bug fixing release
diff --git a/debian/control b/debian/control
index 767a6b6..c5e1297 100644
--- a/debian/control
+++ b/debian/control
@@ -6,12 +6,14 @@ Priority: optional
Maintainer: Manoj Srivastava <srivasta@debian.org>
Standards-Version: 3.9.6
Build-Depends: groff-base, debhelper (>= 9.0.0), po-debconf, file,
- gettext, libperl4-corelibs-perl, dpkg-dev (>= 1.16.0)
+ gettext, libperl4-corelibs-perl, dpkg-dev (>= 1.16.0),
+ libfile-fcntllock-perl
Package: mailagent
Depends: ${shlibs:Depends}, ${misc:Depends}, perl, libperl4-corelibs-perl,
- debconf (>= 1.2.0) | debconf-2.0, exim4 | postfix | sendmail | mail-transport-agent
+ debconf (>= 1.2.0) | debconf-2.0, exim4 | postfix | sendmail | mail-transport-agent,
+ libfile-fcntllock-perl
Architecture: any
Description: automatic mail-processing tool and filter
Mailagent is a mail delivery agent, and can be programmed to